IE11 With Adblock Plus Very Slow When Run As Fully Virtualized [V7B][M838]

Summary - Loading IE 11 in virtual browser takes forever and I can’t surf
Can U reproduce the problem & if so how reliably?:Yes, always.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:opened Launched IE 11 in virtual browser but takes for ever to load and even longer time to get to any web site.
If not obvious, what U expected to happen: Virtual IE 11 to start as fast as not virtual
If a software compatibility problem have U tried the conflict FAQ?: no
Any software except CIS/OS involved? If so - name, & exact version:Adblock for IE
Any other information, eg your guess at the cause, how U tried to fix it etc:Unisntalling Adblock Plus fixes the issue. To note:it works with other browsers Chrome, FF and Dragon.
Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
Diagnostics attached

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
Exact CIS version & configuration: CIS 7.0.308911.4080
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:HIPS in safe mode/BBlocker set at blocked/ FW at safe mode as by Chiron
Have U made any other changes to the default config? (egs here.):proactive
Have U updated (without uninstall) from a CIS 5?:No
if so, have U tried a a clean reinstall - if not please do?:
Have U imported a config from a previous version of CIS:No
if so, have U tried a standard config - if not please do:Yes, problem is there even with the default one
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:Win 8.1 sp1 64 bits, UAC ON, ADMINISTRATOR, ACER laptop Aspire E1-531-4861 model
Other security/s’box software a) currently installed b) installed since OS: a=SANDBOXIE 4.8, Malwarebytes v., Hitman Pro 3.7.9 build 212 64 bits b) McAfee Internet Security, AvastFree 9, AviraFree 2013

[attachment deleted by admin]

Deactivating or best uninstalling adblock for IE solves the problem. Tried to post the dumped zipped file of IE 11 biut it’s too large! Anyway, this bug is minor! ;D

Thanks for this report. By the way, for future reference the bug reporting format for this Beta is simpler than the main one. It can be found here. That said, don’t worry about it. You’ve supplied more information than is necessary.

I do have a few questions though. First, are there any other addons installed?

Also, do you experience any slowdowns when the browser is run normally with adblock plus activated?

Finally, did you run the removal tools for those anti-malware products which used to be installed, but are now removed? The removal tools can be found on this page. If not, please run them and confirm that the issue still remains with IE.

Thank you.

Hi Chiron!!! I currently always use Google chrome and FF with a lot of extensions and it’s fast enough but chrome is loading much slowly because of X-Notifier (for my emails) and may be disconnect (which is about privacy)but still faster than FF and IE 11.Dragon is kind of a Comodo Google chrome. same thing except it’s more strong on privacy but say less used internety wide As for IE 11 I never use it. It is the slowest browser even naked of any extensions…I lose about 2-3 MB/s in download speed with it so I hate it! Anyway I get a better performance by always loading a blank tab as a start page. IE 11 only has Adblock and several extension for Classic shell explorer and all (but it was slow even before) and I intend to remove the redondant Google toolbar and even the Lexmark printer toolbar which is no use.
As for uninstalling other security suite, I use their tool, their uninstaller, thoroughly reboot several time, delete every folder left and Use CCleaner registry cleaner for the end job, sometimes I go as far as digging in Regedit… Carefully… I’m well aware that leftovers may interfere with future antiviruses especially beta but what you want to do computers are sold with preinstalled security software! With that said, with all the stuff in Google Chrome and almost nothing in big mammoth IE 11 the fist runs faster and is smoother with CIS 6 & 7. Hope I get the same protection from CIS in all my browsers! ;D

Please try IE11 in the FV sandbox with only the Adblock extension allowed. Does this happen if all other extensions are disabled?


Sorry Chiron, I got rid of AdBlock for IE now on this computer. I guess it’s only a minor problem for only a minor part of the crowd that tries this beta! :wink:

Can you please link to where you installed IE from? I will check this out myself, but I want to make sure I’m using the correct extension.


I upgraded my OS from Win 8.0 to Win 8.1 and my IE 11 is coming from there. To get the AdBlock extension for IE just Google it, it’s easy. I just choose to report this as a bug as all my other browsers use Adblock extension with no problem at all but I guess IE gets a special and different treatment from CIS or Malwarebytes maybe than the other browsers… !ot!

The reason I wanted a link is because there are many variants. For example, are you using Adblock Plus, Simple Adblock, Adblock for IE, Adblock IE, etc… Please provide a link to the one you are using so I make sure I’m not checking the wrong one.


Given I was among the first to upgrade my OS from Win 8.0 towards 8.1 back in October I can’t remember if I Googled Adblock for IE before that or after. If so, the problem is well understandable, the extension was the one for IE 10 which was upgraded towards IE 11 keeping Adblock for IE10. I’m not sure! Going from IE 11 just click here Adblock Plus | The world's #1 free ad blocker to test and install the one for IE 11. I think you don’t need to test the one for IE 10 gone IE 11… It’s obvious it’s gone crash or interfere with correct operation of the browser to me. Once again we solved the problem!

I tested this, but cannot replicate the issues. After installing Adblock Plus in IE I was able to surf just fine in the FV Sandbox.

If you reinstall Adblock Plus does the problem still occur? If so then this may be related to your IE settings. Did you make any changes? If so which ones?
Also, please attach the KillSwitch Process List to your first post. It’s possible this is caused by a conflict between processes which are on your system but not on mine.

Thank you.

PM reminder sent.

Hi Chiron,
What’s the KillSwitch Process List? How to create this. I post a zip file of minidump of IE 11 virtualized process. Yes, I installed AdbockPlus 1.1 for IE and I get the same result. I get my new tab starting page after a long while and gave up completely on surfing any page. My settings are default in IE 11 and didn’t touch anything. From my KillSwitch program I clearly see IE11 blocking with AdBlock process. I got rid of all toolbars except the one of my Lexmark Bubble-jet printer/I don’t think it to be a problem.

[attachment deleted by admin]

Thank you. To create the process list you start up KillSwitch. Then click on the KillSwitch tab. From there select “Save Current View”. This will create the process list, which you can put in a zip file and attach to your first post.


Posted Killswitch process list. Thanks a lot Chiron. Waiting for a fix, not important or urgent as I avoid IE 11 or use it rather usually with sandboxie but would like to use comodo sandbox too. Thanks!!! :smiley:

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have informed me that they have not been able to replicate this. Is there anything specific to your system which you can think about which may shine light on where this problem may come from?

Hmm! no! Can’t see. In my case, I don’t use IE 11 and in that case I can uninstall Adblock for IE 11 and solve the problem. Thanks and don’t waste your time on this. Let’s keep moving toward CIS 7 FINAL… Thanks anyway for empathy, I appreciate it!! :wink:

Okay, in that case I will move this to Resolved.

Thank you.