ICS, uTorrent and Comodo firewall


I have 2 PCs connected each other and sharing internet by using ICS and i can’t open the port for uTorrent. Here’s the situation:

cable modem < PC1 (WinXP x86, ICS server, have installed Comodo firewall, don’t have installed uTorrent) < PC2 (Vista x64, ICS client, have installed Comodo firewall and have installed uTorrent)

Problem is that i can’t make Comodo to open port in PC1 for uTorrent ??? . I’ve tried various tutorials and guides trying to open port, but nothing helped. When i was using ZoneAlarm on PC1 it worked without any problem. Since i switch it to Comodo, uTorrent starts showing red circles instead of green marks.

Sorry for my bad english :slight_smile: . Hope someone be able to help me :slight_smile: .

Nobody knows? ???
All i need is someone to tell me what settings should be in My Network Zones, My Port Sets and Global Rules for PC1.

Thanks in advance :slight_smile:

Read the following tutorial I made. Substitute the port number and protocol for your situation.

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok.

That will open the port for you. When you didn’t make special rule for your p2p program make it Trusted for testing (you can make a tighter rule afterwards).

Just did it and nothing - port is still closed :frowning: .
Did this on both PCs.

Can you show me a screenshots of your Global Rules of both PC’s? They are under Firewall → Advanced -->Network Security Policy.

Can you also post screenshots of the firewall logs of both pc’s? The logs are under Firewall → Common Tasks → View Firewall events.

Did you make the p2p client trusted?

Here it go:

Global rules are the same at both PCs so here’s only 1 screenshot:

Firewall log for PC1:

Firewall log for PC2:

Those are the only things that have something to do with torrent. Rest of the logs didn’t seems relevent (logs about games and stuff like that :)).

P2P client was trusted but i had switched it back to the application rule that was suggested in that tutorial made by greek guy.

Can you show me the incoming port rule? It should look like

Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port  

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

First off close Utorrent. Then open CIs and go to firewall at the top. Then look for something called “stealth port wizard”, open it up and select the second setting " alert me to incoming…" and hit ok. Then open up utorrent and wait for the pop up from CIs asking if you want to allow an incoming connection, hit allow. There you go it should work just fine.

It’s looks like that, just with my port & mac address.

Just tried, and still nothing. No pop-ups from Comodo for uTorrent.

It must be pop up. Maybe you turn it off or something. You are the first who tell it wont work!!! Try again and
be sure that you close uTorrent!!!
close torrent program. Open CIS → firewall → stealth port wizard → select second one ( alert me to incoming…) → hit ok → open torrent program and wait for alert from CIS about incoming connection, allow.If there is no Pop up start download or seed!!!

Before you do that, don’t forget to delete any utorrent rule that is already created and then do the above procedure.

I got the pop-up, accepted and still got yellow triangle and port checker still says “port closed”.
Trouble is in PC1 not in PC2. Somehow it blocks port 16661 which i’m using for torrent. Check those screenshots of PC1 logs.

edit: just checked log from PC2.

Asked - UDP - - 5351 - - 5351

Should I follow that EricJH’s tutorial but putting port 5351 instead of uTorrent’s 16661? ???

Your Port must be between 52000 and 63000. Try it! My Port is 59827!

Tried everything and port is still closed >:( . It seems that only thing left to do is just to uninstall Comodo frmo PC1. Simply, I don’t know what else to do ??? .

Just wanted to let you know that I “solve” the problem :slight_smile: . I’ve bought the router, forwarded ports and now everythings working just fine :slight_smile: .

Admin can lock this topic if anybody else doesn’t need it anymore.