Icon Vanished - comodo screen will not open since update

Was running comodo firewall 3.9 and updated to 3.12. The tray icon vanished and i can not open comodo even though it seems to be running when i look in msconfig.
If i try to manually install latest 3.12 version i get no icon and it wont open. If i install 3.9 or 3.5 it works fine but as soon as it auto updates the icon goes and comodo will not open…

Please advise

Running Vista ultimate 64

Please try a clean install and after rebooting use this clean up tool to get rid of possible left overs.

Do notice this tool is made for 32 XP. You will need to clean out the Appdata folders yourself; when doing so don’t forget to look in the Virtual Store folder. Not on 64 bits but I do sorta recall there are separate Program Files folder for 32 bits and 64 bits apps. Please take a look there as well and remove stuff from there.

For reference. The tool looks in the following places (forget about removing the legacy keys):

Uninstall CIS and reboot. Then run [url=http://system-cleaner.comodo.com/]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See: https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_info-t17220.0.html;msg119226#msg119226

Thanks for the reply. I tried that but it made no difference. The latest Version of comodo will not show an icon or open when i cleck the shortcut. It does not matter if i do a clean install or if i auto update from an earlier version. I am back to running version 3. 9 which is the only other copy i have. It shows the icon correct and opens when i click on it so the issue must be related to version 3.12.

Can you look with Task Manager to see if cfp.exe (the client) and cmdagent are running.

Do yo have other security programs running in the background? If so try disabling them for the moment and see if that makes a difference.

All i got running is Avast which makes no difference even when i turn it off.

The services seem to be running but i still can not open comodo, have no icon and i do not get any pop up whenever a new request to connect to the internet occurs.

As soon as i go back to version 3.9 all works as it should.

Is there a link for version 3.10 and 3.11 that i can try out or is there a newer Beta version i can try as 3.12 just does not want to work on my system.

COMODO Internet Security 3.10.102363.531 Released
COMODO Internet Security 3.11.108364.552 Released

Thank you i will try them out and report back…

OK got 3.11 working fine. Tried to update to 3.12 again and once again it failed to work with same issues as above. Reverted back to version 3.11 and all is fine .

Most odd that 3.12 just will not work on my setup.

Thank you for your help and links to 3.11
I guess for now i’ll have to stick to 3.11 and hope the next update will be ok unless you have any other ideas as to why 3.12 is being so weird on my PC.

There are more than several reports of the Comodo icon not showing up in Windows XP. That is a Windows problem as it also happens with other applications: http://www.tech-pro.net/howto_013.html .

If I understand things correctly you cannot open the CIS screen when clicking on the CIS icon at the desktop. Is that correct?

I running Vista 64 so not sure if the winXP issue applies and no other icons have this issue only 3.12 comodo.

If i have 3.12 comodo installed and i click to open it via Start / programs menu is does not open.
If i have 3.11 comodo installed i can click in start menu or the tray icon and it opens perfect.

Something in the 3.12 software is making my system play up.

Could you summarize what is running on your system as described in Important: how to submit bugreports (read this if you want them fixed). This will help the devs to reproduce the problem. See if you can add the information in your opening post.

Thanks in advance.

After updating to CIS 3.12 I got smth like PawGan have described.
When my Windows XP boots up, CIS icon does not appears. If i start CIS via shortcut, icon appears. I’ve tried to delete windows\prefeth*.* and Documents and Settings\User\Local Settings\IconCache.db. After I do this, next time I reboot windows, CIS icon appears normally, but after one more reboot CIS icon problem goes on.
EricJH, thank you for the link, disabling “SSDP Discovery Service” solved the problem :-TU

sorry for poor English :-[