ICMP not configured [M1462]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Clean installation;
2: When I try to set some options ICMP protocol, is not shown;
3: In the event log shows the block but, it is not possible to configure the firewall.
4: To simulate the “error” simply allow all incoming traffic and outgoing ICMP then try to ping a server and see all the firewall log (see atachment)
5: string reference:

<string id=“24067” value=

One or two sentences explaining what actually happened:
You can not configure some options ICMP protocol
One or two sentences explaining what you expected to happen:
Ability to configure ICMP settings correctly
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
The problem arose with the release of the stable version of comodo internet security 8.

Exact CIS version & configuration:
Comodo Internet security 8.2.xxxbeta- proactive security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
antivirus - enabled
Auto-sandbox - enabled
Firewall - Enabled
Have you made any other changes to the default config? (egs here.):
The addition of blocking and release of certain ports of the firewall rules in the overall
Have you updated (without uninstall) from CIS 5 or CIS6?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
Even with a clean installation, (s) option does not appear
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows seven service pack 1 (x64, x32 or x86bits), Windows 10 release preview, windows xp, real machines and Virtual (vmware and virtualbox), admin acount, disabled UAC
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=no b=no

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here and put the resulting file in a zip file. Both should then be attached to your post.
Note that additional information may be requested by the processing Moderator.

list of applications is not necessary.

more complete information about the same problem :P:https://forums.comodo.com/bug-reports-cis/comodo-firewall-incorrectly-identifies-application-that-send-icmp-echo-requests-t110323.0.html

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

You CAN configure a firewall rule to allow or block the ICMP protocol if falls under the global rules list, and you CAN configure an application rule as long as it applies to the ‘System’ application. But that is the issue, say you create an application rule for the windows built in ping utility(C:\WINDOWS\System32\ping.exe) and treat it as a blocked application firewall rule set, you will be able to ping out. But if you apply the blocked rule set to System and try to use ping, then all applications including ping.exe, that use the windows api to send echo requests will fail.

the devs have requested more info about your global rules and have also requested a video of reproduction.

I have made a video of the issue, hopefully this satisfies the devs. - YouTube

Thank you very much. I have passed this on to the devs.

Hi liosant,

Please see explanation here.

Moving to “Resolved” section.