icedragon.exe blocked from accessing graphics hardware

This happens to me only when viewing Facebook. It doesn’t happen in Firefox.
I can find no setting in Windows 10 that lets me stop this from happening.
Can anyone advise how to solve this please?

man, im not trying to hijack your issue here, it blocks me on w7 too to a site i have gone too for 5 years now, same principle tho, i dont know what CID has done with updates lately but seems the security issue is the culprit, just over the top,
and eric, id like you to PM me please


Are you using x32 or x64 version of CID, from what i can see from my tests it does not show this error, can u leave it on Use recommended performance settings and see if the error still appears

v. (64-bit)
Use recommended performance settings has always been checked.

Sorry for the delay in my reply. This forum does not send a mail to alert when a reply has been received even though the option was checked.

Edit: Problem solved. “Use recommended performance settings” needs to be unchecked.
Edit again: NOT solved. It’s doing it again.