I Keep Getting "Shockwave Flash has crashed" error


A few hours ago shockwave flash stopped working in CD. Every time I load a page with video on it I get an error saying that Shockwave Flash has crashed. Both CD and shockwave are up to date and shockwave is working in other browsers. Does any body have any idea what the problem is and how I can fix it? Thanks in advance for any help!

I have the same problem with some sites.
It works fine on youtube, but most of the sites that have a youtube video integrated cause my shockwave to crash.
A good example is this site: How to Bring Back Google Chrome's Old New Tab Page « Internet :: Gadget Hacks

(yes, i hate the new “new-tab page” and try to find a way to change it back to the old version)

If you can check if this causes your shockwave to crash as well, let me know. I don’t have any extensions installed that could cause this.

[edit] http://www.sandboxie.com crashes it also [/edit]

Youtube video’s will play. It is only shockwave flash that is not working so any [&every] site that uses shockwave flash causes the plugin to crash.

I have also noticed that I can no longer block third party cookies because the option is greyed out. I suspect that these issues have something to with the most recent version of CD. When I go to download the latest version of CD, it downloads ver 29 instead. When I have automatic updates enabled it does update to ver 33 but when I disable auto-update and try to manually update it, the action fails due to a signing error.

Hi ValarMorghulis,
Now I am not sure if it is by design to allow PrivDog control of this function or a bug. :-
If you disable the PrivDog extension the ‘Block third-party cookies and site data’ option becomes available again.

This may not be relevant to the flash issue.

Kind regards.

Hi captainsticks,

I have privdog disabled but I have had it enabled previously and didn’t have this issue. I did initially suspect a plug in because there is a little plugin icon at the end of the greyed out text.

I went to double check what the icon was and now it seems I can block third party cookies again. Very strange because I haven’t changed any settings at all - haven’t even been using CD [apart from checking if the problem still exists] since shockwave crashed.

Hi ValarMorghulis,
For me at least it is PrivDog blocking/disabling the mentioned option.
I just tried it with Dragon portable, with the same result as my installed version.

Update from me.
I uninstalled CD, removed profile and manually all folders involved. A normal re-install didn’t work for me.
To be safe I uninstalled Flash as well.
Then I re-installed all, downloaded manually the latest Flash and now all seems to be working fine.

Guess this is a “me too.”

Starting today, every time I try to play a video on Facebook, I get a frowny-face at the video place and a message bar saying “Shockwave has crashed.” Using Comodo Dragon browser.

Other peoplele’s comments
I don’t know if it’s your problem but for me that happens when my memory is full, So refreshing now & then to empty it prevents that for me.

& someone else told me having to many applications running [at] once will cause that also. If you have A lot of tabs open close some & see if it’s better.

I get the same, I clear the cache several times a day and it still happens intermittently. I have no idea what to do, so I’m waiting for some clever answers here too. (I also use Comodo Dragon).

Refreshing clears the memory for me, Last night on A FarmVille Group Page A couple of people were having A problem with Dragon also, Switched to another browser & they were fine, Maybe Dragons having issues?

I have a memory and processor tracker; mem is only at about 60%. I have restarted it; no change. Only one tab open. Just started out of the blue today, and is consistent (not ‘sometimes,’ ALL the times.) I have not seen any notifications that Dragon has updated, but don’t really know.

I went to the main site and downloaded the setup file using the big DOWNLOAD button. When I ran it, it asked if I wanted to DOWNGRADE from to v29-something.

Sure seems stuff is all messed up right now with versions and flash/shockwave functionality.

I tried to downgrade to v29 to see if that would solve the shockwave flash crashing, but after install, it said it could not use the profile, which was a v33 profile, and wanted me to specify a new profile folder. Since I did not want to do that, I ended, then reinstalled v33 as a repair to be sure all was back at a consistent place. So, the shockwave flash failure is still with me.

The crash is happening only when accessing videos on a Facebook page. Directly at youtube, they work fine.

And now, I do not know what is going on. I disabled all extensions, and a video played. Started re-enabling one extension at a time, and thought I had narrowed it down to “Disconnect.” Then suddenly, it worked with that enabled. Enabled ALL of them. It worked…then it didn’t. I cannot analyze this to where it makes any sense at all. I do know that others have reported it as well, so I am sure it is not just MY configuration causing it.

Sorry for the three-in-a-row, but I am at my wits end.

I do not know what changed, whether this is something in v33 causing it or what, but Comodo Dragon is now essentially useless to me–or at least so annoying I won’t use it until this is fixed. It is how I read Facebook, and there I look at videos quite often–but not any more. Can’t.

When was v33 released to distribution?

I don’t use FB, so that explains why I am not seeing some of the Flash issues reported.
The debatable question remains.
Should the browser be created to be compatible with a plug-in, or should the plug-in be created to be compatible with the browsers?
IMO, the second option. :slight_smile:

Hi movrshakr,
I guess you could use a Portable Dragon of a previous release for sites that have issues, this will leave the current installed version intact for everything else.

Kind regards.

In fairness, I must report that tonight I am having no occurrences of flash failing on Facebook. I have made no changes in the extensions that are enabled.

I have no idea what is going on. Would like to hear from some of the other people who were having the same issue.

4 HOURS LATER: Crash! Just tried a video and the fail is here again.

Still no joy with shockwave player. With regard to the comment:

Should the browser be created to be compatible with a plug-in, or should the plug-in be created to be compatible with the browsers? IMO, the second option.

I agree but I have 6 other browsers installed and they are all working fine except for CD so in this case Comodo Dragon is the issue. I still think that the fact that version 29 is on the Comodo website instead of ver 33 is part of the issue.

Hi ValarMorghulis,
I understand your statement about it being Dragon specific, let us hope the Adobe plugin/Comodo Dragon issue is solved sooner rather than later. :slight_smile:


Hi there, don’t know if I should make a new topic!

I’m getting the same issue. I’ve tried getting a clean install of flash, didn’t work. My twitch.tv streams were visually lagging so I restarted my computer and reinstalled, now it crashes everytime I open up a twitch.tv stream…

Hi and welcome n00boxular,
Unfortunately there have been some recent issues with the current Dragon and Adobes Flash.
There is a workaround posted in the link below, other than that let us hope a future update solves the issue with the Adobe Flash plugin sooner rather than later.
Dragon 33 - Flash Player issues workaround!

Kind regards.

I have opened a ticket with comodo and I am awaiting their response.

I also opened a ticket.
Their response:

"There could be conflict with Shockwave and other extensions that are enabled in the browser. I would recommend to uninstall Comodo Dragon and reinstall it to fix the issue. Please get back to us for any further assistance. "

I still haven’t gotten any response to my ticket.

I would recommend to uninstall Comodo Dragon and reinstall it to fix the issue

It would be an idea to update their website so that people can actually download the latest version before they tell people to reinstall CD. As I have mentioned before, I am having no issues with shockwave on any other browser using the same extensions [the majority of which are default in CD] and I have uninstalled and reinstalled several times with no change.

Do you mean it has been an entire week and they still have the wrong version being downloaded!?