I have the latest version but is sais UPDATE

I have been using comodo registry cleaner- the best ever! Mainly because of the sorting between safe and unsafe to delete. I then upgraded to comodo system cleaner because it is the most up to date version. It was fine, then a few days ago it said update. I clicked and it did it then it said that system cleaner crashed when it said to exit out of system cleaner to update it. it crashed and the update stopped and then everything is fine. I tried updating a few more times with that same out come. Then I tried to reinstall it and update again and same out come. Then I realized that the comodo website has the version I had.

So I think there is a bug saying there is an update but there really is not.

I would also like to thank everyone involved with comodo. It is literally the best and most trusted software to me. I use avast home, comodo internet security with anti virus real time off, threat fire, superantispyware free, a2 free, comodo backup, and comodo system cleaner, revo uninstaller. Those are my security/utilities software. In case it can help.

I have the same problem and spent (wasted) a half hour early this AM trying to update. Current version I’m using is 1.0…60093.19. Perhaps the COMODO CSC development team will fix this minor glitch in the next real update.

Question to moderator - should issue this be posted as a bug?

Otherwise, great program. Thanks COMODO.

Best Regards to all,

Am seeing this on my end as well.

I’ve reported this ages ago and everyone were acting like i’m speaking some alien language… 88)

Man it is annoying. It is a great product from a great companie but the problem is that the early versions have bugs to be fixed.

Hello… If I understand correctly ( I may be wrong ) Comodo is asking you to update to this version;

No it is not because that new 1.1 whatever is a beta update so it is not officially realeased yet. so I still have the latest update but is says update, it a bug. it is fixed in the new beta version though. cannot wait for it to come out to public.

thank you comodo you are life savers!

Just installed it, good to know that it’s updated and it’s just a bug.

yes everything is fixed in the new 1.1 version which is OUT of beta! The ONLY thing i don’t like about the new version, which isn’t really counted is that most of the features are out, but its all good b/c i heard comodo moderators say themselves that they are being put back in one by one.