I have a problem and I hope COMODO can help with a new piece of software

I recently bought a HP computer and was hoping to use Comodo’s Time Machine on it. But I found out that my hard drive on this new computer has a RAID hard drive and that Comodo’s time Machine doesn’t support RAID hard drives. I really like Comodo Time Machine and my wish is either make a new new compatible version of Comodo’s Time Machine that will work on RAID hard drives or create a new program that will work on them also please make it so someone with a RAID hard drive also can use a defrag program on it. Right now Comodo Time Machine you can’t use any defrag program on your hard drive the program deactivates Windows or any other defrag program from working on your system with Time Machine on it. So will you please come up with a piece of software that will do both these things and take a snapshop of my system like Comodo’s Time Machine does. Thank you.

Hey there :slight_smile:

I have search and I believe here is an alternative solution.

Valentin N

MJR1 if you’re trying to backup or clone you’re HP laptop computer I would used Macrium Reflect FREE Edition Macrium Software | Macrium Reflect Free Trial and you can also setup a USB Bootable device using Macrium Reflect how to create a bootable Linux USB stick see link Macrium Software | Blog

It is a HP desktop computer with a single Hard drive but CTM says it is a RAID hard drive and when I tried to install it anyways on it it Cause my Windows 7 64 bit system fail to boot up and only removing CTM help with the failed boot up.

You can’t only have one RAID harddisk; RAID is is a technology that provides increased storage functions and reliability through This is achieved by combining multiple disk drive components into a logical unit, where data is distributed across the drives in one of several ways called “RAID levels”.

For more info about RAID

I think you can change somethings in your bios.


Then there is something wrong with CTM it reads it as a RAID HD. Plus I read there is a single HD of RAID on Wikipedia. and that other program as far as the Macium Reflect the free version every time I choose a file to put the image in it said file is already in the image file choose another. And as far a disc goes it wanted to use 77 and a half gigs to do the job. So I hope Comodo will come up with something because I am not the only one that has a HP Machine out there. And we need something like CTM also.

MJR1 can you post a screenshot of you’re problem so Comodo Mod can solved you’re problem easier

User is asking CTM to be compatible with RAID (Which Currently It Is Not)

If you have only one disk with RAID; then ignore and continue (Please search for RAID in the CTM Board)

If you have more then one in a RAID enviroment then please uninstall/cancel and wait for a compatible version;

Hope this helps


If I install CTM on my computer and try to reboot it fails to reboot and a program I have called Speccy from the makers of CCleaner also shows I have one hard drive and it is a RAID type of Hard drive witch CTM says it wasn’t made for. So I am wondering if any plans on making either CTM or another program with it’s ability RAID and Defrag program friendly. Plus a friend took the cover off my desktop and checked and yes there is only one Hard drive in the case. And even using Windows system restore didn’t help the reboot problem only using the boot menu of CTM and telling it to uninstall CTM did my Windows 7 64 Bit HP desktop boot up correctly again.

It will be RAID Friendly Hopefully! :slight_smile:

Have you disabled such option in BIOS?


The same friend who help me find out about how many hard drives I have advice me without knowing how they meaning HP is using the RAID on my Hard drive it might make my window 7 unstable or not work at all. So he advice against doing anything to it without more information on how HP is using RAID on this hard drive.

Ok; We’ll just have to wait for a RAID Compatible Version of CTM


I tried disabling RAID it in the bios the first setting no boot up the second setting it booted up and my HP computer downloaded additional drivers and rebooted. After that I tried reinstalling CTM and it seems to be working for now my system rebooted fine hopefully it will stay that way and thanks for the help.

Your Welcome,

Could you do me favor just to make sure we’re not stepping on any toes sorta speak;
Check The Windows System Logs
Start > Run > eventvwr
and glance over to see if there are any events that happened (from the time you booted up the first time with the option disabled in BIOS)



Forgive me I am new to Windows 7 and am not sure how to find system logs to find this out.

Now Worries (Press/Hold the Window Logo Key (By the Left Ctrl/Alt) and Press R then type in ‘eventvwr’ without the ‘’ and then Windows Logs > Is there any “Errors” ?

Hope this helps


No Worries;
Press and Hold the Windows Logo Key (By Ctrl/Alt (Left side of the keyboard )) and press R > eventvwr > Windows Logs > System
Check if there is any ‘errors’

Hope this helps :slight_smile:


I finally stumble across the log file nothing. Then I went back into Bios and double check what I did there and here is what I did. First I went to SATA Controller Mode and change it from RAID to IDE mode that is when it wouldn’t boot up. Secondly I went back into Bios and set the SATA Controller Mode to AHCI mode and it booted fine and then the computer downloaded the additional drivers and it rebooted fine so then I installed CTM and that was that. Everything went fine after that. Forgive me I’m not very much techie so Bios isn’t something I do often. Sorry I took so long to explain what I did and how I did it.


Just making sure there are no errors happening in the background;

:slight_smile: Your Good to Go! :slight_smile:

Thank You For Taking Your Time To Explain :slight_smile: