i can't update error code:0x80004002.please help!!!!

:slight_smile: :slight_smile:
please help~

When I click Update Virus Database …

Let Comodo fully load up before trying to update.

What version of CIS are you using? Look under Miscellaneous → About.

Notice that all version 3.12 and older won’t get updated anymore. When using an older version please update to the latest version.


This is my first time in the Forum. I’m not a very techie person, but I know the basics.

I can’t get my anti-virus to update. It last updated on 1-5-10. Now I’m getting an error message saying that I need to test my internet connection. However, obviously, I’m connected.

I have the free version 3.5.57 on WXP SP3.

You cannot export/import the old 3.5 configuration in the new 3.13 due to changes under the hood.

One other question is how long I can leave it in "learning" mode. I don't know how to answer the questions it asks me, when it's out of "learning" mode. I know that's off the subject, so ignore it if you like and I will find out another way.

Any help appreciated.


When not very techy it is recommended to set D+ and Firewall to Safe Mode after a couple of days or “learning mode” as you call it. Comodo will then automatically learn the rules for safe programs. That will save a lot of work by comparison.

Regarding answering alerts. When you know the program it’s self is safe and from a known safe source you can basically allow it. For D+ make the program trusted. For firewall there are several useful profiles for typical applications: web browser, email program and ftp client speak for themselves, use outgoing only for updaters of programs and Trusted as shortcut for more 'tricky" programs.

If you have anymore questions regarding rules please start you own topic in one of the Help Boards.

I’ve installed CIS Ver 4.0 and have two error states. Can’t update Antivirus (error code 0x80004002) and Defense + is not functioning properly! I have uninstalled run Comodo registry cleaner - rebooted - run cleaner again. Reinstalled CIS and rebooted but still no joy. I am running Win XP SP4.
Why can’t I get this to work??

OK I rebooted a third time and now it shows that the database was updated Friday April 16, 2010 7:53:07Am. But if I click on the update I get the same error message and Defense + is still showing not functioning.
Help would be appreciated.

uninstall comodo, reboot, run this clean up tool https://forums.comodo.com/install-setup-configuration-help-cis/cleanup-tool-for-comodo-internet-security-t36499.0.html, reboot, reinstall a fresh download of CIS, reboot, try to update then. Also make sure non of the setting in IE ( connection tab ) have been changed ( such as proxy and so on).

Well that didn’t work back to same error message and Defense + still shows same error. I thought I’d try this program but there seems to be too many problems with it. If it can’t be installed easily I don’t see the point of using it.
Thanks for the help.