I cant uninstall and reinstall or upgrade

Hi all

I have read the posts in the other similiar topics and I havn’t tried everything yet

My error when I run the isntaller is " You seem to be having Comodo installed using older version of installer’ and it tells me how to remove it from controll panel …It is allready removed…its removed allready from program files and msconfig and services and reg
and I d/loaded CPF_Setup_2.2.0.11_BETA I get the same error message

and it is showing as ON in the XP security centre
I have what this guy had but I cant uninstall the wbem folder as in his steps?>>


I am not sure if this is an issue but I did get a virus and used system restore to go back to an earlier time…and that messed up Comodo…SO I thought reinstall it .will work…but then I had all this trouble…I love the firewall I just want to reinstall it but I cant until I uninstall it…well it is uninstalled in theory just it is still there in the securty centre xp thing

any way thanks for any help :slight_smile:

V2.2.anything is old. Where are you downloading this from?

The latest release version is 2…5.62. Download it from http://personalfirewall.comodo.com.

I have what this guy had but I cant uninstall the wbem folder as in his steps?>>


The instructions do work. Please download the latest version and carefully go through the wbem steps one by one. It should be a simple case of stop service, delete folder, restart service (or reboot).

Let us know how you go,
Ewen :slight_smile:

Hi Ewen

that worked with the wbem folder I was stoopidly trying to delete the folder itself and getting access denied any way I re-read the instructions and it was the sub folder “repository” so it all worked and its gone from the security center
I d/loaded the newest version from the link you posted but it still wont install it is still refering to uninstalling the previous version

I am still getting the following error message

“You seem to be having Comodo Firewall installed using older version of installer”
Please go to->Start->control panel Add or Remove programs section and un-install Comodo Firewall."

It has been removed from control panel allready so there must be some thing the installer is finding that it thinks its still installed?

I originaly d/loaded it from snapfiles.com only about a month ago and I just tried that version again and its the same error

I will try another reg cleaner and see if that helps or could there be some DLL files that need to be deleted before it will reinstall?

Thanks for the help

Hi Lost & panic!

I found myself in the same situation, however on W2K machine, wich doesn’t the same “security center” as the XP.

I had previously uninstalled Sygate Personal Firewall (without any error messages or unexpected events). Then I attempted to install Comodo Firewall, which went well almost to the end install Window. Even before I had time to click “Finish”, I got en error message (which I unfortunately didn’t write down).

When I set out to try to install again, I now got the same error message that you did:

“You seem to be having Comodo Firewall installed using older version of installer”
Please go to->Start->control panel Add or Remove programs section and un-install Comodo Firewall."

I tried the “repository” fix, but didn’t help either.

Finally this solved the problem:

  1. Booted into safe mode
  2. Searched the regedit for “sygate” - and deleted all instances
    • Note: Some legacy entries could not be deleted.
  3. Searched the regedit for “comodo” - and deleted all instances.
  4. Reboot.

Now I was able to install.

Probably of no interest, but I’ll mention it anyway:
In my first and failed attempt, I chose to do a “manual configuration”, where I changed the install folder and nothing else.

In my second and successful attempt, I chose to “full automatic” install.

And on a final note: I send my condolences to coworkers and friends of Mr. Eric Emanuel.

Did you resolved this problem???

Who? - Me? - Yes, I did; At least for my own computer, as mentioned in the above post from me. I don’t know if my description helped “Lost”, though, as it seems he had given up by the time I passed through.

Sort’ve OT, but I have an installation problem with Comodo as well. Actually, installation isn’t the problem, it’s activation. When I enter the license key and try to activate, I get an “unknown error” message and activation doesn’t work.

I’ve opened a tech support ticket but so far everything they’ve suggested has failed to fix the problem and it’s been referred to the programmers. I’m thinking, though, based on this thread, that some legacy element of Zone Alarm in the registry may be causing the problem. I do understand that it’s pretty hard to get rid of every trace of ZA.

If you’ve gotten it installed, it shouldn’t be connected to traces of ZA (although computers can be odd things…).

I hate to ask, but I have to, as it’s a common error - did you copy and paste the Activation Code from the 2nd email you received, rather than the Order Number from the 1st email? (I’m sure that’s already been covered, but I have to ask… I promise it’s not an insult).

Next, another basic question - were you connected to the internet when you attempted Activation?

Third (and last, for the moment) have you tried uninstalling/reinstalling CPF? (I’m not saying you need to, just asking if you have…)


It’s the 2nd time I’ve tried to reinstall comodo, everything worked well however it always skip the activation window…(?), instead comodo will show up but with services off…(?)
why did comodo twice shut of it services and need a reinstal…?
Any suggestions

Sounds to me like something is interfering with the installation, or causing an error (or perhaps you have a corrupted download of CPF). Or an old firewall still installed (not completely uninstalled) that is causing conflict…

Are you running any HIPS-type of protection (Spybot’s Teatimer, Avast’s Webshield/Netshield, SSM, Prevx1, CyberHawk, etc?). A CyberHawk user has noted that it interferes with installation of CPF, although afterwards all works well together. Perhaps something like this…?

If you don’t have any of these types of protection actively running (you would temporarily disable them to install CPF), you might want to download a new copy of CPF from Comodo’s website. Endpoint Detection and Response, Free - What is EDR Security?.


PS: Welcome to the Forums!

Yes, I’ve done all those things. Comodo even sent me the activation code again but it still won’t work.

Perhaps there is some element of ZA left that’s causing problems. Stranger things have happened…

Have you checked in Services (go to Start/Run, type “services.msc”) for any Zone Alarm entries? If they’re there, double-click, select start type to “Disabled”, apply and OK, then reboot.

Or your startup entries (go to Start/Run, type “msconfig”) go to the “startup” tab and look for any ZA items. If they’re there, uncheck, click Apply, then OK, and reboot.

Then after that looking at the Registry for Zone Alarm entries…