I can't get v3 firewall to allow company of heroes to play

Can somebody help me out here please, as i have been at this thing for over 4 hours and am completley lost!!! ???

Hi Splishy,

Please explain exactly what happens when you try to play the game. Any screenshots of the event would be great as well.



Hi Max, thanks for the quick reply. Basically I can’t even get the firewall set up. I asume its blocking ‘company of heroes’ from playing online, as no game servers can be found.

I have looked at the various solutions to setting up online gaming with v3 firewall, but for one I can’t browse for applications to be able to create rules.

Any ideas mate?

I think Company of Heroes uses the following ports to connect to the lobby, host games and accept connections:

UDP 6112
UDP 30275
UDP: 9100

Perhaps you could check firewall logs to see if there are any blocks listed for these ports.

If there are blocks recorded for the ports I think you may need to create a global rule to allow UDP through these ports. If you create a rule to allow UDP through the above ports and put it above any block rules in Global Rules (under Network security Policy in Advanced firewall tasks) it should work. Not sure whether you need to restart after adding the rule.
Also, make sure the application is listed as trusted in application rules.

I think I have set up the ports as per your instructions. It mentions only two though;


I’m stuck now at the ‘making it a trusted application’

my linksys router with built in firewall was so much easier ???

Hi Splishy,

My experience has been with setting up Battlefield 2 for online gaming. What I had to do was create a rule in my Computer Security Policy for both BF2 and it’s companion PunkBuster designating them both as trusted apps. I’m not sure if COH uses punkbuster or any other app for online gaming but make sure if it does you include this as a rule in your CSP. Even after doing this, the first couple of times I launched them I still received a few pop up warnings from CFP when these apps were trying to connect to servers so patience is required. You will also probably see some blocked intrusion attempts in your firewall logs as well.

I’m at work now so I don’t have access to CFP to be sure about the following but here goes: to create a rule in your CSP, go into Defense+>Advanced>Computer Security Policy. Click on this and you should see a listing of various applications and how Defense+ is treating them. In the upper right side, there should be an “add” button; click that and go to browse. Locate COH and select it and and then choose the predefined designations (not custom). A drop down menu should appear to the right and from that select “trusted application” then click ok/apply on all on all windows. Do this for all executables associated with COH.

Again, you will probably have to launch COH a couple of times to get through the warnings from CFP - make sure to answer them so that it treats COH as a trusted app- but after that you should be able to game online without trouble.

Hope this helps and let me know what happens.



Hi Max, I have followed your instructions and still it will not work. Why does this have to be so complicated to set up? I need a step by step guide as I am getting no where. I will go through the forums yet again and try to find one. Thanks again for all your help guys its appreciated :slight_smile: Its this program, its doing my head in ???

From the help manual:

Training Mode: The firewall will monitor and learn the activity of any and all executables and create automatic ‘Allow’ rules until the security level is adjusted. You will not receive any Defense+ alerts in ‘Training Mode’. If you choose the ‘Training Mode’ setting, we advise that you are 100% sure that all applications and executables installed on your computer are safe to run.

Tip: This mode can be used as the “Gaming Mode”. It is handy to use this setting temporarily when you are running an (unknown but trusted) application or Games for the first time. This will suppress all Defense+ alerts while the firewall learns the components of the application that need to run on your machine and automatically create ‘Allow’ rules for them. Afterwards, you can switch back to ‘Train with Safe Mode’ mode).


Hi Splishy,

I’m sorry to hear it didn’t work, I know how frustrating that can be. If at all possible, please post screenies of your defense+ and firewall logs as well as any alerts. Again, any screenies would be most helpful to determine precisely which aspect of CFP is causing the issue. I would also like to see a screenshot of your CSP rules and how COH is designated.



To have ports open for incoming traffic for applications read this tutorial: https://forums.comodo.com/faq_for_comodo_firewall/tutorials_a_compiled_resource-t6167.0.html;msg45504#msg45504 . It is written for p2p clients but the logic is the same.

Are you using a fixed internal IP address for your computer?