I cannot install PD.


I several times installed PD. It got installed seemingly OK. It creates its files in folder “C:\Program Files (x86)\AdTrustMedia”. But it doesn’t appear in FF and CID. I know it must be PD icon like in CD (I don’t have CD on my PC now). There’s no PD in “Extensions” and “Plugins” of both FF and CID.

Maybe I missed something?

Thank you.

Hi Solarlynx,
This maybe a silly question, but have you restarted the browsers after installing PD?

Hi Captainsticks,
Thank you for your answer. Your question isn’t silly as I am ignorant in many things here. :slight_smile:
But anyways yes, I restart my browsers after installing PD. I even restart PC. Browsers are not in Sandbox.

Hi Solarlynx,
It should appear in the ‘Extensions’ list and also an icon.

Do you have any other 3rd party extensions or plug-ins that could be blocking the install of PD into the browsers?

Are both browsers the installed versions (Not portable) and in there default locations?

To be honest I am not sure what is happening.

No it doesnt appear in the “Extensions” list.
It appeared only in the Administrator account in FF, not in CID.
I uninstalled CID with Advanced Uninstaller, erased the profile and folder with CID. Then installed it again without any extensions. Then reinstalled PD. It doesn’t help anyways.

They are not portable, installed in their default locations.

Maybe some suggestions?

for your answers, I assume you did not try to uninstall PrivDog, try uninstalling it completely clean temporary files (ccleaner. …) and do a clean install of PrivDog

If this dont work, maybe it’s a browser problem, a extension bug or something?

It doesn’t help as well. ???
I even reinstalled browsers.

Hi Solarlynx,
Is the PrivDog.xpi file present in the following location?

If no, try placing the .xpi file within the zipped attachment there and see if it installs.

Thank you.

[attachment deleted by admin]

Hi Solarlynx!

Which version of Privdog do you have ?
Which Windows?

Thank you!

The latest PrivDog from its site.

Windows 7 SP1

Thank you.

Captainsticks, thank you very much, I’ll try it ASAP and report.

You can see also in


What version of firefox do you use ?

Thank you for your feedback!

[attachment deleted by admin]

Thank you very much. It worked!

I use the latest FF 24.0.

And now it is there, when I’ve done like Captainsticks said to do.

Thank you very much.

I am glad it worked Solarlynx, I am still puzzled as to why it didn’t get added when PrivDog was installed.

Maybe the reason is that I moved users profiles from C: to D: and made a lot of jumps between snapshots with Eaz-Fix time machine. Consequently there’s collected some junk making sometimes unpleasant surprises like this.

Most likely the reason.