I broke Windows Update - either with CSU, Program Manager or CCE

Help! I somehow managed to break Windows Update(see attached) (Win7-64bit) after running System Utilities (complete cleanup), Program Manager (unchecked some autoboot items) and CCE. It is totally my fault; I’m sure I deleted things I shouldn’t have.

I’ve tried restoring everything from System Utilities and re-checked everything in Program Manager. I’ve also tried Windows system restore, but it can’t find some of the deleted files, so it won’t restore anything. I’ve also tried the Windows Update Fixit.

Is there any way to fix this? It’s the only thing I’ve noticed as broken, but there very well may be other things.

[attachment deleted by admin]

Try running system file checker and see if that helps to fix this or not.

Yeah, tried that too. It said nothing was wrong… :stuck_out_tongue:

Did you try the fixes on this page?

Also the System Update Readiness Tool? might help.

Try reseting windows update components. There`s a FixIt or you can do it yourself (long winded though).

If it comes to the worst try a repair install


Thanks all! I ended up doing a complete reinstall, which sucks, but the tools just weren’t doing it and I’m not good enough at navigating the M$ website to find a download of just Update. Just working on reinstalling ally programs.

I’m going to image my drives in case i do it again. :stuck_out_tongue:

That’s a very good idea. Images can come in quite handy sometimes. :wink: