I believe I've done something wrong and I'm not 100% sure.

Okay this is not going to be very easy for me to explain I can only do my best and I’m not 100% sure which section I should be posting this problem too.

My Comodo Firewall is set to Proactive Security using FW/D+/Sandbox and see below my current Sig so you know what else I have on my PC.

  1. I’ve add my firefox browser permanently run inside the Comodo Sandbox and it set to “Limited”

  2. I run my firefox browser and I went to ShieldsUP website to test my firewall GRC | ShieldsUP! — Internet Vulnerability Profiling  

  3. I click onto “Proceed” and then click “Continue”

  4. I’m ready to test my firewall then I click onto “Common Ports” while ShieldsUP is checking my firewall everything has “PASSED” perfect “TruStealth” rating.

  5. I did the same thing to test “All Service Ports” and everything has “PASSED” full Stealth.

  6. I went to my Comodo firewall at the main screen looking at the Network Defense section where it said "The Firewall has blocked 0 intrusion attempt(s) so far. The Firewall security level is set to Safe Mode

  7. My Proactive Defense said The Defense+ has blocked 1 suspicious attempt(s) so far. The Defense+ security level is set to Safe Mode

  8. I went to Defense+ Events log saying that my firefox flag said Sandboxed as Limited mean my firefox is running inside the sandbox “great”

What I don’t fully understand is why is the ShieldsUP saying I’ve “PASSED” perfect “TruStealth” rating when the Network Defense said "The Firewall has blocked 0 intrusion attempt(s) so far, when I run the ShieldsUP the block number should not be 0 during the ShieldsUP test the block numbers supposed to be counted.

Am I doing something wrong ??? and I’ve run the Comodo Leaktest and I have a 340/340 pass in the comodo leaktest.

Normally, the firewall on your router blocks all unsolicited inbound connections unless they are associated with outbound connections or configured to do so. (Port Forwarding, DMZ etc.)

Your Computer (CIS) [#3] <<< Router (the firewall) [#2] <<< GRC [#1]

Your Computer (CIS) [#1] >>> Router (the firewall) [#2] >>> GRC [#3]

Sorry offchu I don’t fully understand what you saying, any way I’ve done another test and do more research to see which is the best solution for me but I’m still lost.

Okay I’ve removed my firefox browser pathing inside the sandbox as No. 1 in my first post.

I’ve run ShieldsUP and my firewall has “PASSED” perfect “TruStealth” rating in “Common Ports” & “All Service Ports” and everything has “PASSED” full Stealth without having firefox running inside the sandbox.

Now this is very interesting and I’m still totally lost, I went to my Comodo Firewall main screen to see if the Network Defense section where it said "The Firewall has blocked suddenly the numbers block have been counted after the ShieldsUP test it mean the comodo firewall is blocking during the ShieldsUP test and it working.

What I still don’t understand having firefox browser running inside the sandbox when the Network Defense section where it said “The Firewall has blocked” stop counting the numbers of blocks during the ShieldsUP test, and then suddenly I removed the firefox from the sandbox inside and the “The Firewall has blocked” counting start showing up.

It there a bug somewhere inside the comodo firewall using the sandbox or am I going nuts ??? can somebody please do a test for me is better to have firefox running inside the sandbox as I’m still protected by Comodo Firewall while browsing the web and my PC is protected as well or it doesn’t make any different as I’m still passed by the ShieldsUP test.

I’ve heard a lot of people saying is better to run my firefox inside the sandbox because I’ve never used sandbox before, I know how to keep my computer clean and safe.