doesn't work on mobile.


Tried going to from two different mobile phones on two different networks and both came up with what is shown in the screenshot below.

Please look into it. =)

[attachment deleted by admin]

I can confirm that the new certificate is not trusted by Android 4.1.2

My phone’s running Android 5.1.1, the other one I tried I don’t know.

Same for me on my Android 5.1.1 Nexus 7 tablet.

Fails in Chrome and Firefox…both latest versions.

Opera gave me the option to proceed anyhow, that did connect.
Lollipop 5.0 Running Alliance ROM 8.0

Anyone from Comodo able to explain where the issue lies and a timeframe
for a possible resolution?

Looks like it’s fixed…

Anyone know how?

According to it is now trusted by Mozilla and Microsoft. The issue “unable to get local issuer certificate” seems to have been fixed.

Chrome on my phone warns that a weak signature algorithm (SHA-1) is used. Certificate #2 has SHA-1: SSL Server Test: (Powered by Qualys SSL Labs)

From my observations, they were missing chain/intermediate certificate(s).

I cannot see Comodos server admins missing such a basic step during certificate installation (:NRD) (:NRD)

Will this ever be fixed? :a0

[attachment deleted by admin]

It’s working fine for me.

Edit: Or do you mean specifically the SHA-1 part?

Yes, SHA-1 and the invalid Certificate Transparency information.

The image is from Chrome 45 on Android 4.1.2 (Galaxy Note). I just checked Chrome 45 on Android 5.0.1 (Galaxy Note 4), and it’s fine there. :-\

I checked it on 5.1.1 so perhaps it’s an issue relevant only to Android <5?