HP Games & Game Console Blocked from Internet

Help! Need my games ASAP! :frowning:
Seriously, I downlooaded Comodo Firewall Pro v3 from MajorGeeks because I wanted to try it out before getting CIS. Well, now that I’ve downloaded v3 (which I guess is no longer supported officially), I can no longer use my HP Games console to access the web. I get a message from H Games (Wild Tangent) that I am behind a firewall. My games worked perfectly fine before I downloaded Comodo Firewall Pro. I am on disability, do not have a television, so the Internet and my games mean a lot to me. I would like to get them back as soon as possible and am starting to think that maybe having the best security is noot worth it if I can’t use my computer for the things that matter in my life.

I checked out archived messages for FirewallPro v3 on this Comodo Forum site and found one message and reply that seemed relevant. Here it is:

  "Welcome to the Forum, Nofsdad.

Do any of these included games require internet connection to run?

Remove the rules from D+ (Defense+/Advanced/Computer Security Policy) Scroll down and select the game files. Remove them and click ‘Apply’. exit out of the GUI.
Right click on the CIS icon, and place Defense+ into Training mode.
Then run each game fully and then exit the game. Right click the CIS icon again and place Defense+ back into the mode you were using prior.

Your games should now run correctly."

I tried all off the above and it didn’t work. I tried it a second time. I still could not go online through the HP/Wild Tangent game console. I also lowered my Internet security to medium by going to Internet Explorer and I also lowered to Low the setting for Trusted Sites in IE. Yes, the Windows Firewall is turned off.

I right clicked on the Firewall Pro icon in my System Tray disabling first my Defense +, then trying to go online, then disabling my Firewall and trying to go online to Wild Tangent. Finally I disabled both Defender+ and the Firewall and tried to go online to WIld Tangent through my HP game console. Nothing worked. I reset my Firewall Pro settings and decided to leave a message here on the Forum BEFORE I DELETE FIREWALL PRO

What do I do in order to have Comodo Firewall Pro running at the same time as my HP/Wild tangent games? I am generally Intermediate in terms of computer ability and knowledge so please explain in as simple terms as possible any procedures I should follow to fix the situation.

Many thanks in advance for helping!


What version are you using? The latest is 5.10.102363.531; download it from here: http://personalfirewall.comodo.com/download_firewall.html . Majorgeeks surely needs to update their website regarding Comodo…:wink:

I am not quite sure what these games need regarding firewall as I am not familiar with them. For now start with putting the Firewall in Training Mode. Make sure to delete the previously made rules first.

When that doesn’t help I need some additional information. I need to know if the games need one or more open ports for incoming traffic. Do you have a url to the support pages?

Also I would like to see a screenshot of the firewall logs of around the time you are starting a game. They can be found under Firewall → Common Tasks → View firewall events.

[sub]Edit: set the proper version number

Just a correction, latest version of CIS is 3.10.102363.510

Fixed it to *.531… the *.510 is from another version.

Thanks for answering so quickly. Before I answer you in full, Eric, I have a quick question. Before downloading version 5.10.102363.532 do I need to uninstall the version I have currently. If so, what is the best way to uninstall with the least amount of problems? (I’ve had problems with various uninstallers from or for Noton Systemworks on a couple of earlier laptops so I’m cautious about uninstalling utilities).

When I’m on my own computer I’ll give you the additional info you’ve requested. I can tell you that I did put the Firewall in training mode when I found myself unable to access the games and that did not make a difference with the old version of Comodo Firewall Pro.

You need to uninstall the old version and reboot. You can not use the configuration of the old firewall with 3.10. There have been too many changes. You will have to start clean.

In case of doubt regarding the uninstall you can run this unofficial clean up tool after the uninstall and reboot: https://forums.comodo.com/install_setup_configuration_help/cleanup_tool_for_comodo_internet_security-t36499.0.html;msg259617#msg259617 .

I assume you mean that I should uninstall CPF with Add/Remove under Windows Control Panel, correct? And then run the unofficial tool at the link you provided. I’ll do that as soon as I can and get back to you.
Again, many thanks for the quick (and understandable) support. :-TU


And then run the unofficial tool at the link you provided.
I’ll do that as soon as I can and get back to you.
Again, many thanks for the quick (and understandable) support. :-TU
You’re welcome and keep us posted. :-TU

I did everything you recommended (downloading and using the unofficial Comodo Uninstall tool). I got strange error messages about certain files and access denied etc. and at the end it said that CFP shouls be gone from my computer. Talk about mixed messages!!! 88)

I hardbooted. I can’t find any signs of Comodo when i search on certain files in hidden and archived files using Advanced Search. However, I still cannot access my games. ??? Not even when I turn off my Windows Firewall (which I reenabled prior to uninstalling CFP v3). Very strange since before installing CFP I had no problems at all accessing my games online!

Here’s the url for the Game support: http://hp.wildgames.com/support/technical.aspx#download

Do I do a System Restore back to a time before I installed CFP? (That would be August 15th - I checked; I have such a restore point).

Well, I posted too soon. i do have remaining folders and files on my PC although Vistas’s Advanced Search with Hidden and Archived Files checked didn’t find them. I found cssurf.exe here: Local Disk (C:) Program Files.COMODO.Safesurf.cssurf Its an application so I assume it was cssurf.exe. I also found my folder with the uninstall batch file and the read me file. I sent this last folder with the batch and the read me off to the garbage by deleting them.

I haven’t had this much trouble since I tried to delete Norton 2 laptops ago. It trashed my computer; a tech at a shop had to reload everything after wiping my harddrive. Then he removed Norton Symantecs the way “They do everyday at his place - GeekSquAD” and my ability to go online through dial-up was trashed. All I could do was go to the Wi-Fi cafe across the street 8am-7pm. Anyway, I’m getting the feeling we may have to do somethiing like wipe my HD again. Today after “uninstalling” Comodo I’m having problems with my touchpad and keys; there’s a delay to everything - or maybe its unrelated and there’s a scan going on in the background I don’t remember scheduling (they’re on the weekends).

I don’t know what else to do to get Comodo cleared from my laptop and my ability to play games (and use other such programs online.

Thank you for your PM. I downloaded the Game Console to see for myself and managed to get it to work. As with regard to the left overs of Safe Surf you found. Look in Control Panel → Software if it is still installed there. If so uninstall and reboot. Safe Surf is now integrated in CIS.

The easiest way to go with games is using Training Mode. Before doing so delete all the rules you made for the console related programs and for your games in D+ and Firewall. The console related files I found are:

Where can you find the rules for D+ and Firewall?

  • For D+ go to Defense + → Advanced → Computer Security Policy
  • For the Firewall go to Firewall → Advanced → Network Security Policy → Application Rules
    Here is a little tip for looking up rules in the list. Click on a rule then push ctrl +f and start typing c:\Program Files\HP in the process of typing you will get suggestions.

Put the Firewall in Training Mode. This can be done under Firewall → Advanced → Firewall behaviour settings → now set the slider to Training Mode. Now put Defense + in Training Mode as well. This can be done under Defense + → Advanced → Defense + settings.

In Training Mode the Firewall and D+ will learn the rules without alerting you. It speaks for its self this mode should only be used if your system is free of malware. That being said when in Training mode start the console and fire up your games one by one and play with them for a couple of minutes and end them and close the console. When done put back the sliders of D+ and the Firewall to their previous settings (write the positions down before you set them to Training mode).

Now with D+ and Firewall back in their old settings fire up the console and play your favorite games. It should work now.

Next time you download a new game put the Firewall and D+ temporarily in Training Mode and play the new game(s) for a couple of minutes and then put back D+ and Firewall to their previous settings. You don’t need to delete the old rules now; that was only to get started.

I noticed one thing when I was doing manually allowing in a step by step process that the console is a bit impatient and quickly says something was not right. That problem was not there when using the Training Mode procedure.

Keep us posted and let us know how things worked out for you. Also let us know if you problems getting other programs to work.