How to unblock blocked svchost.exe


I have recently installed CFP and it seems to work really fine. The problem is that yesterday I managed to block svchost.exe (win XP) by denying it in the pop-up window (I did not check the “remember” checkbox, though) and CFP prevents my computer from connecting to the internet with the firewall on since.

I found the process included neither at the application nor at the component monitor and tried allowing it in the application monitor but it did not help. CFP keeps blocking the process, according to the log it is blocked by the application monitor.

Is there any way how I can get it going again apart from reinstalling the software?



Hi kaca, welcome to the forums.

If you said Deny without ticking the Remember box, then a simple reboot will clear the block.

I naturally tried that in the first place, but it did not help.


If there’s no rule at the app monitor, my only guesses are that either you’ve got CFP set to “block all” regardless of rules (you should set that to “custom” by default), or that it’s some rule at the net monitor that’s firewalling Internet.

I had the same problem and what I did is uninstall firewall reboot install again ,leave firewall alone ,click on windows update the minute you do that the firewall alert will popup click yes remember and you should be all set,hope that helps.

I finally decided to reinstall the whole application and it seems to work ok for now.

Thanks for the suggestions, anyway.


Just wanted to bump this thread, since I am having a very similar issue.

In my case, I did deny svchost initially, and did tell it to remember it, but soon realised that this was a mistake since it was blocking my DHCP requests. I’ve since edited the entry to allow svchost all activities, skip the parent check, allow invisible, and skip advanced - but it still blocks DHCP requests. Every time I release/renew or plug into a different network (it’s a laptop, so this is frequent), I have to close CFP, get my DHCP address, then relaunch it.

Haven’t tried reinstallation yet. Kind of frustrating that I should have to do that.

And no, I’m not blocking everything either (stuff works fine once I have my DHCP address).

Hi EnigmaticSoul

check applications like alg.exe and svchost.exe in Appliacation monitor and see whether they are blocked. These process can cause such problems if blocked!


Hello, Dam.

Thanks for the suggestion. alg.exe was never listed in the list of applications at all. Per my original post, svchost was listed and permitted all forms of communication (though I had blocked it initially in error). Reinstallation solved the problem, and a couple of other minor things that I didn’t even know were not working properly.

Maybe this is my problem too. I don’t have alg.exe in my application list, and svchost.exe only appear once in the list with the protocol ‘TCP/UDP In’. Maybe I need a protocol for outbound too? ???

I just searched for ‘alg.exe’ on my harddrive with the search function but it didn’t find it, so maybe only some people have that file.

I’m having a similar problem involving svchost.exe

I was browsing my favorite comics on, and Comodo put up a warning saying that scvhost.exe was trying to access something-or-other. I don’t remember exactly what it was asking, but I’ve been surfing the net using Comodo for several months now, so I figured that it wasn’t anything important. Without thinking, I clicked Block with Remember still checked.

Now, things are strange. I can browse the web, and I can still visit, but I can’t access any of their individual comics or use their search feature. Here is an entry from my COMODO Firewall Pro Log:

Application: C:\WINDOWS\System32\svchost.exe
Action: Blocked
Source IP:
Source Port: 53
Destination IP:
Destination Port: 55025

I went to Comodo → Computer Security Policy and told it that svchost.exe is a trusted application, but I still can’t view those websites. It says that I have no blocked Network Zones or Applications.

What can I do (besides completely reinstall Comodo)?



Locate SVCHOST.EXE in the lsit and edit its settings to remove the BLOCK.

Ewen :slight_smile: