How to remove executable from the container?


One of my application is running in the container and the weird thing is that even if I close the application, the executable remain in the container even after I restart my PC. I have flagged the file as trusted, I have also flagged the folder of the application to be ignored, but the executable is still running in the container and I can’t find any way to remove it from the container or to stop the process. If I try to reset the container I get an error saying it failed to reset the container. If I go to the Task Manager the process is not listed, I also tried using command prompt to kill the process by ID but I get the process doesn’t exist error. The executable is sitting in the container at all times, even if I restart the computer and I can’t run the application outside the container, not even if I set it to be trusted or ignored.

I remember someone mentioned it is a bug and will be fixed in the next update scheduled to be released in a week. It was months ago and I still have this problem.

Comodo Internet Security Premium 10 Version
Windows 10 Pro 64bit Version 1803 OS Build 17134.285

I would appreciate any help.


you can reset the container in the main interface> advanced view> containment tasks > reset container and dont forget adding rule to auto containment for your app >settings > containment > auto containment > add rule > select ignore > browse your apps directory

further info > Auto-Containment Rules, Containment Security Software | Internet Security | COMODO

Thanks for the info but as I already mentioned if I try to reset the container I get an error saying can not reset the container and I have added the file to the trusted list and I have also set the entire folder to be ignored by auto containment but the process remain in the container anyway yet the process does not exists when I try to kill it…

So my question is.

How can you kill a process in the container that doesn’t exist as far as Windows concerned?
How can you remove a process from the container that doesn’t exist as far as Windows concerned?

Tried resetting the container, tried adding the file trusted files, tried setting the entire folder to be ignored by auto containment, even tried to turn off auto containment, the process remain in the container whatever I do, yet it does not exist so I can not kill it. So how can I remove it from the container?


you can use killswitch terminate option

Yeah it is a bug that is fixed with CIS 11 which you can get by uninstalling and installing using the installers from the release topic.

Thanks for confirming the bug and the link.
I’m not so much of a security enthusiast and don’t really want to use beta (unstable) software to protect my system.
Is there any estimate when v11 will be released to the public and push an update to v10 users?

Thank you both.

It is no longer in beta stage as it is a final/stable release they don’t offer updates to internal updater until a least a week later if no major issues are reported.