How to enable remote desktop in v4?

I just updated the Comodo firewall to v4. Suddenly I am facing a problem: With v3 it was no problem to create a rule that allowed Remote Desktop (TCP on port 3389) to my host (from my laptop). Now with v5 I simply can’t get this to work. I see in the logs that this connection is filtered by one of the default '“global” rules (the last, which denies IP traffic).

I’ve set the firewall to “learning mode” - it doesn’t work, although other connections are reported and learned just fine! If I setup a rule myself matching what’s blocked in the log:
→ incoming TCP on port 3389 for “Windows operating System”
…this rule is simply ignored.

What am I missing?

(Windows Vista SP2, no other AV / Firewall installed / active.)

I have the same problem under XP. In any mode CIS 4 connection doesn’t work through the “Remote Desktop”

Attaches itself to the above question, please help.

to let incoming connections through port 3389 you have to create the rule for svchost.exe

Allow incoming TCP from any IP to yours where port=3389

Also, in Stealh Ports Wizard mark option Alert me to incoming connections

  1. Open Comodo Firewall
  2. Click “Firewall” button
  3. Click “Advanced” button
  4. Click “Network Security Policy”
  5. Click “My Ports” Set tab
  6. Click “Add” and select “New Port”
  7. Select “A single port”
  8. Type “3389” click “Apply”
  9. Click “OK” and close Comodo Firewall.
  10. Done.