How to do a repair install of CIS

Hi, sorry if this has been asked before. I did search and could not find anything.

Basically how do I do a repair install of Comodo Firewall? When I run the install program it recognises it is already installed but only gives the option to uninstall or add other components. If I uninstall I presume I would lose all my programs settings so hoping to avoid that.


Do your firewall report any errors? If yes, run diagnostics


This should fix normal installation errors detected by CIS.

Thanks for your reply. I tried the Diagnostics button but it did not find any problems with the installation but clearly there are. It was working fine but since yesterday has acted somewhat like it has forgotten settings, the Predefined Policies are gone (completely missing from the section and also do not appear as an option in the alerts) and many programs are asking lots of questions when they were installed ages ago and working fine. Many want to install global hooks to MSCTF.DLL, I’m fed up of saying yes. As far as I can tell my programs still appear in the Computer Security Pol. /My Safe files lists.

Before anyone suggests, I have scanned for viruses etc and uploaded the MSCTF.DLL file to Virustotal for scanning (it’s clean) and I can find no sign of malware anywhere.

I have now manually restored the Predefined Policies and it does seem better but still seems to be not quite right so I thought a repair install might solve it. Is there no option for that? Ie to re-install but keep all your previously learnt database?

Out of curiosity. How did you restore the Predefined Policies.

I recreated them by adding them manually then recreating the access rights as per a different topic I saw on here. Think I got it right.

However the story goes on. Because I was still having probs I backed up my configuration, uninstalled, then re-installed (this is the latest version as downloaded from the website). Then imported the saved config. and all seemed great. The Predefined policies were present and correct. Then a little later (just now in fact, while replying to this) I checked the settings again and the Predefined Policies are mostly gone again (Trusted Application is still there but the others are gone) so I’ve had to recreate them again.
What is going on here?

Good question. Are you using registry cleaner programs? Did you use one or more of them after the install of CIS? Try putting back the back up copies these programs made.

What other security or system protection tools do you use?

Hi, I used a registry cleaner about a month ago but didn’t notice a problem following that occasion. Haven’t used one recently, since re-installing.

I also use AVG av, SpybotSD (but without TeaTimer enabled), Malwarebytes AntiMalware (without the real-time protection) and occasionally AdAware (with AdWatch turned off).

Currently the settings are holding so fingers crossed it was just a strange glitch.

What is your configuration settings for CIS??? (Right click try icon-Configuration)

If it is Proactive Security you are ought to get these alerts for hooks like MSCTF…DLL. You can see a brief discussion about it here, which also gives a suggestion to contain this particular alert.;prev_next=next

If you want lesser alerts, you can opt internet security (I presume here that you have proactive security).

It is, and always was, on “COMODO - Optimum Security” except now (since importing my saved settings) it says “updated” after too. The link you posted, as one member said in that topic, seems “a little like throwing the baby out with the bath water”.