How to disable cmdagent.exe?

I want to make some tests without any of the comodo firewall components is running but i am not able to close cmdagent.exe. I tried to close it from Task Manager but it says that the access is denied and i am logged in as administrator. Is there a way to disable to process or i have to uninstall the whole program?

You first have to disable all of the sub-components (permanently). Then you should be able to kill cmdagent.exe through the Task Manager. You may have to kill it twice as it sometime starts up again.

To Stop: Start->Run or open Command Prompt type: net stop cmdagent.exe and hit Enter.

To Start: Start->Run or open Command Prompt type: net start cmdagent.exe and hit Enter.

—Edit— Typo, it should be: net stop cmdagent and net start cmdagent

If i run net stop cmdagent.exe i get The service name is invalid.
What other sub-components i have to disable? I have only Comodo Firewall installed.

Sorry, typo, it should be net stop cmdagent (remove the .exe)

Disable (if you have it) HIPS. This protects cmdagent.exe from being disabled by malware. I have full CIS installed and disabling HIPS lets me kill cmdagent.exe through the Task Manager or Command Prompt. Make sure that you run Command Prompt with Administrator Privileges.

When i run net stop cmdagent i get The requested pause, continue, or stop is not valid for this service.

The HIPS is disabled and before running the command i am exiting comodo firewall from system tray, so cis.exe and cistray.exe are not running.

That’s strange. Maybe it behaves differently when you just have the Firewall installed alone. I can kill cmdagent.exe through the Task Manager while leaving cis.exe and cistray.exe running. Maybe someone with a different experience will assist you further. I’m at a loss now. :-\

I think i found, finally, how to disable all components of comodo firewall. First, disable HIPS protection, then in Task Manager close (end process) cmdagent.exe and after this cistray.exe, cis.exe, cavwp.exe.
This way it seems to work.

It’s odd that it’s different from the full install, but if it works, so be it. :-TU

(maybe it’s a difference in config choice, I’m using Proactive Security)