How to delete "undeletable" registry keys? [Resolved]

I just uninstalled Winamp and when searching regedit with the word “winamp”, I encountered one particular branch that I couldn’t delete/modify. When I tried to export, it states it doesn’t exist. It’s definitely not a permissions issue because I already checked that. Even Safe Mode didn’t make a difference. I think there was one member here who experienced the same when he tried to delete a CFP key, but I forgot what program he used to resolve the issue. RegSeeker didn’t detect this BTW.

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Media\Winamp → This one I can actually click on without any error message (and it’s got the usual Default binary value, with the value as Winamp), but deleting it brings up the error. It also has 3 sub-keys that I can’t even open without getting the errors, called: DefaultIcon, InstallInfo, and shell.

Any clues?

[attachment deleted by admin]

Did you boot into the administrator account and try it?

My account has always been in the Admin group. And yes, I’ve even tried the original Administor account itself and in safe mode.

Update! :BNC

Thanks to my great memory ( ;D), I managed to locate that program the other member (Alan) was using (this thread) and deleted that registry and it sub-keys using Registrar Registry Manager (Lite Edition). Shows you how reliable M$ own registry editor is >:(. Even the other version of regedit, regedt32, didn’t work. What I’m unsure of is if this is a trialware or freeware.

Though it’s resolved now, still I like to put additional information for your future reference.
Have you tried Revo Uninstaller yet?
It’s free, by the way…

No, but I have a similar program: Zsoft Uninstaller. I’m starting to see way too many programs that are similar, so if each are calling itself “unique” it would be untruthful. Anyway, I suspect that registry key was there before I even had ZU.

It’s all MSs fault (not sure about Vista) & its nothing to do with permissions (although they can protect registry entries to a certain extent)… basically in XP/W2k you can create a registry entry that, as far Windows is concerned, is invalid. You can create a key/data that exceeds the maximum size (for Windows). It was originally intended for hiding/protecting license keys… but, once that genie was out… spyware starting using it.

Sorry Soya, I would have posted this sooner if I had seen your topic.

You did see it - I saw it in the “Who’s Online?” that day , but you were idle for so long so I guess you were busy. I’ll forgive you :P.

Anyway, you figured out the cause (which wasn’t really my case since that registry key seemed to be small), but your solution would’ve been…?

Who’s Online: Ah well… that proves you shouldn’t read too much into that. Perhaps I did click on URL to this topic (from email), but perhaps that wasn’t the one I was after or something… I just don’t remember seeing it before today.

Resolution: A previous solution (just been checking) no longer exists & the other was to write an small application to do it. Mind you, if this wasn’t your problem… I’ve no idea if any of these would have solved your probably anyway. But… small key? Well, you can create sub-keys (that are also invalid) & these prevent the deletion of the parent. I’ve also heard of small device driver used to keep a lock on the registry entry to prevent its deletion.

Drat, you beat me to it. And I knew right where to look, too. That’ll teach me not to go thru all the posts on a daily basis… :wink: