How to check if Defense+ is working properly?

Today I downloaded an installer from a “trusted” source, but it was an unsigned msi installer, so I guess CFP couldn’t know it was “trusted”.

I ran it, expecting to see the usual Defense+ warning, asking what to do (the one where you mark the program as an installer, and then switch to install mode). To my surprise, the program was installed without any warning.

I was using CFP 4.1.150349.920 and when I checked if there was an update, it didn’t find anything.

So I browsed this forum and searched a bit. Maybe the problem was due to an old config which has been upgraded, probably since CFP 3.x. I didn’t want to lose that config because I spent a lot of time (mine and from people in this forum) setting up the firewall rules (Defense+ rules are a lot shorter).

Anyway, I noticed there was a new version of CFP, so I exported mi configuration, and upgraded.
After that, I activated my configuration and ran the same installer, and this time it got sandboxed (that’s good).

So it seems it is working, but I’d like to be sure. I tried with another installer, but it was analized online and considered safe, so it -again- didn’t ask me if I wanted to install or not. I think I’ll miss that feature.

You can go to Defense+ Settings>Sandbox and deselect Automatically Detect Installers/Updaters and Run Them Outside the Sandbox.

Thanks, I changed it, now I just have to wait until I need to install something to test it.