how to block internet access to all files/applications in a folder?

I would like to block access internet to all files/applications in a folder. Is there any option of giving a * so that all files or applications in that folder are blocked from accessing the internet?

otherwise I would have to block each file individually. is there any easy way out. pls help

You Mean All Applications Installed On Your System Or Only Applications Installed To A Particular Folder ?

Hi w2phoenix.

It theory you could do this, Although I confess it’s not something I’ve actually had the need to do, yet, however, as far as I know, the method exists.

You would need to create a new protected folder within Defence+ (My Protected Files), once done you can select that option within the firewall rule creation dialogues.

There should be a section in the help file, or select on the ‘What do these settings do?’ link on the bottom of each dialogue box in CIS to find out more about setting up new file and folder groups under ‘My Protected Files’

If You Want To Block All Applications Under A Particular Folder
Go to Firewall>Advanced>Network Security Policy
Click on Add>Select>Browse
Under the fine name type the path with an * At The End (Eg. d:\app*) and hit enter
Select “Use A Predefined Policy” And Choose Blocked Application From The Drop Down Menu And Click On Apply
And Its Done. All The Applications Under The Provided Will Not Be Able To Access Internet

Note: Make Sure That There Is No Other Rules With Network Security Policy For The Applications Under The Folder And Your Firewall Behaviour Settings Should Be In “Safe Mode”

Thanks to napsterz & Toggie for the quick repluies.

Well the method suggested by napsterz worked well for me as it easy and straightforward. :-TU

You Are Always Welcome :slight_smile:

So Comodo ask me the same question about a Magicjack loading, but won’t stop “any” application from launching as many web pages it wants. When I didn’t have a 64bit system I used Zone Alarm. I didn’t have to ask a question on a firewall stopping what a fire should. Stop things from freely connecting to the internet without my permission! Argh!!! WTH! I tried what was suggested in this forum thread, but I tested a few apps (like Quicktime), and it gets through free, and easy.

Nothing will connect without your permission, providing you have configured the application correctly.

If you would like some help to understand why you have problems, please post some details in a new thread.

napsterz’s method doesn’t seem to work anymore (if you follow the instructions, enter the path, and hit enter, it doesn’t let you continue).

Does anyone know another way to do this?


It still works. Have you tried clicking the Open button instead of pressing Enter?

If that still does not work, you could set up a file group to do the same thing, but it isn’t as simple.

Go to Defense+ → Computer Security Policy → Protected Files and Folders. Click the Groups button and select Add → A New Group. Type the group name and click Apply.

Now scroll down the groups list and click on your new group. Click on Add → Select From → Browse. Now you can either type the file path with an asterisk and press the + button, or browse through the catalog tree to find the folder you are looking for and click the → arrow to add it to the list. Click Apply, then Apply again, and finally press OK.

Now you can go to Firewall → Network Security Policy and Add → Select → File Groups then select your new file group and give it the Blocked Application policy.

Edit: Typos…

Now they have a complete new interface and I cant find what to do.
Pleas help!

Uninsulated Comodo, to mutch bla, blink, bla :slight_smile: