How to block connection to neighborhood Wi-Fi (unknown/unsecured)?


I want to block my kids laptop to connect to any unknown wi-fi / ips / macs. Is this possible, any ideas?

My Home getway Wi-Fi is a but I’ve notice that my kid is using a neighborhood Wi-Fi to connect and serf when ours is off on not allowed hours.

I have tried with no success to use the blocked zones but how to tell a rule to block uknown wifi data or connection that is not from my router?


There are a few possibilities. In Windows, under manage wireless networks, the properties for each network has an option for disabling connections. However, if you can obtain the MAC address of the neighbours routers - you may have an option in your router to display this, otherwise there are plenty of freeware wifi scanners - you can create blocked zones using the MAC.

So if I have my mac router address can I tell CIS to use only this and not anything else? I want a solution using the Comodo.

After many attempts and a few tests I think I found a solution to this. Please test it and tell us here if it is working for your pc :P0l

So if you want your PC not to connect and exchange data with unknown and probably unsecured networks (like neighborhood WiFi) you can use Comodo Internet Security Premium firewall rules and options to establish this. I will try to help you out here with these following steps:

Make sure you have a fresh backup of your system and settings. To backup your Comodo Internet Security Pro: Managing Personal Configurations | Comodo Internet Security | Internet Security v6.2

First we need your Home Wi-Fi or LAN router MAC ADDRESS.
Connect to your home Internet Router/Getaway and if a CIS popup asking you what type of network you are connected hit the HOME. Try to serf and open few websites. If you’re surfing/downloading ok, then follow the following cmd.
A cmd like “arp –a” will probably will give us right away the getaway ip and mac address we are connected to. Please refer to Router MAC Address - How to get router MAC address step by step for more info.
Write down your HOME (00-00-00-00-00-00) MAC address and the ( IP internet address.

Under the FIREWALL SETTINGS we deselect the “Automatic Detection of private networks”

Under the NETWORK ZONES we add New Network Zone name like “Not Blocked”. Under that Network name we add New Address->Type: MAC ADDRESS->Select the Exclude option->input here your home MAC address

Again, under the NETWORK ZONES we add New Network Zone name like “My MAC”. Under that network name add New Address->Type: MAC ADDRESS->deselect the Exclude option->input here your home MAC address

Now, under the BLOCKED ZONES we Add->Network Zones->Not Blocked

We hit the OK, and this will save our edits. Please be careful anything you change here is supper sensitive and it’s a good idea to make notes or do a backup every time.

Under GLOBAL RULES we will edit the first two firewall rules to use our Mac address.

So the first: Allow All Outgoing Requests If The Target Is In [MyMac]->Destination Address->Type:Network Zone, Zone:My MAC
We hit the OK, and this will save our edits.

Second one: Allow All Incoming Requests If The Sender Is In [myMAC]->Source Address->Type:Network Zone, Zone:My MAC
We hit the OK, and this will save our edits.

4. Please note that this will probably not allow DHCP automatic ip registration, so we need manually change our PC adapters IP settings to use a static IP for your network. Helpful info: How to Change Your IP Address (Windows) (with Pictures) - wikiHow,

Example: If our router ip is then we add on the adapters IP the following settings:
Getaway: (this from the first step)

Moreover if you want to add more parental control to your pc you can try to use dns service from
OpenDNS: Family Shield by OpenDNS

That’s it :slight_smile:

Nice work. Good thinking… :slight_smile:

Thanks, but I just find out it doesn’t working on win7. Is that possible the same rules to work on XP and not in win7??? I dont know maybe something is missing… :-\

I did manually add the rulles on 2 pc with win7 but the pcs wont ping or tracert any address. The bizard thing is that the pcs have internet and surfing OK!!!

Moreover I cant remotely login to TeamViewer if the firewall is on. I have disable it ??? We have to find a workaround…

Please, any ideas to fix this? What I’m doing wrong?
Can I export settings from one CIS and import them to another computer CIS settings and work, OS is oriented to this?