How to allow my new Pocket PC to connect to the PC?

When I am connecting my new Pocket PC (Symbol MC70) to the PC using USB connection, after a message in the system tray “acquiring network address” appears for some time, the connection is not established. If I turn of Comodo to Allow All the connection is established.

What should I do?
Do I need to create a new Network Control Rule or do I need to add a Zone?

Thank you in advance for any suggestions and help.

Hey Dmitry,

You’ll generally need to make a network zone and set it as trusted. PDAs will usually make a connection to the host PC using the address range 169.254.2.X.

Hope this helps,
Ewen :slight_smile:

Hi Ewen,

Thank you very much for your help. I am going to try using address range from to .9.

By the way, I was thinking today to do the same, setting up a trusted zone but I didn’t know what IP address to use. So, if you didn’t tell me, from your experience the address of 169.254.2.x, how would one find out?

Again, I appreciate your help.


Easy peezy, Dmitry,

  1. Disconnect from internet (just to be safe)
  2. Set firewall to ALLOW ALL
  3. Connect PDA
  4. Once connectionis established, click START - RUN - and type CMD
  5. Step 4. will produce a DOS-style window
  6. In the DOS window, type in ipconfig /all and press ENTER
  7. Step 6. will display a listing showing tech details of all current IP connections
  8. Look for the connection that concerns your PDA and locate the allocated IP address

Typically, the PC will have a connection address of and the PDA will and address of

Build the zone according to the address range discovered by the above process, set the zone as trusted and you’re done.

The only remaining things to do is to click ACCEPT or DENY to the actual executables used for the connection and synchronisation.

Lastly, remember to set the firewall back to its normal security settings and to reconnect to the internet.

Hope this helps,
Ewen :slight_smile:


Thanks a million for your help!



Your directions were very clear and seemed simple but something still does not work:

Here is what I did:

  1. Opened COMODO
  2. Opened Define a new Trusted Zone Wizard.
  3. Specified in this wizard a zone named “My PDA” range of IP from to
  4. On the Finish step of this wizard, I selected zone “My PDA” to be trusted.

I can see now when I go to Add/Remove/Modify zones my new zone “My PDA” with the range as defined in the wizard.

Yet, when I plug in my PDA, I still get “acquiring network address” message on the system tray and then no connection. I restarted PC too, in case this makes a difference.

What am I missing?



Sorry to trouble you again. I was mistaken in my previous message. After establishing a trusted zone the networking connection between the PDA and PC is established.

The problem, however, is that ActiveSync cannot connect to the PDA. When I ran a troubleshooting utility (I believe which is part of ActiveSync) it pointed me to a MSFT page that indicates that ActiveSync communicate through port 990. Is it possible that COMODO blocks this port? If so, how would I indicate to COMODO not to block this port?

Again, thank you in advance for any help and/or suggestions.


Is there anything pertinent in the firewall logs?

Please post an extract as an attachment.

Ewen :slight_smile:

I swear I didn’t make any changes from yesterday. Today I came to the office, connected PDA to the PC and everything is working.

I am not going to argue with success :).

Ewen, Thank you very much for your help.

LOL. No problems, Dmitry. It might be worth while clearing the logs, setting all rules to log and then connect the PDA. Once the connection has been established, turn off logging and the logs should have an accurate trace of what happened during the connection. This info may help if it decides to stop working.

Ewen :slight_smile:

Excellent suggestion about getting a trace of what is happening. But I can’t find where to turn off the log. I go to Activity and click on Logs. I can change the max size of the log but don’t seem to see where to turn it off. What am I missing?

The attached screenshot should help.


[attachment deleted by admin]


Thank you very much for a picture illustration of how to stop logging alerts.