How to add "Microsoft Update" URLs as safe sites?


I know this is a stupid question, but how do I give the following “Microsoft Update” sites untrammelled access to my PC:;
https://; and

I recently ran the “Trend Micro HouseCall 6.6” online scan and was told I had several Operating System vulnerabilities, i.e. missing Microsoft updates, but, when I tried to download the missing updates, via the “Automatic Update” feature, I was informed I needed to add the above Microsoft sites to my “Safe” list.

How do I do this simple thing?

Thanks for any help anyone can give me.

Hi & welcome. :slight_smile:

Adding websites to Comodo Firewall is not possible, you can only have rules for applications and network policy. The “Safe” list you refer to may address your internet browser!


You have to determine what app issued the msg to add it to your “Safe List” then add the apps to that app’s list. But my suspicions would be the msg referred to adding them to IE’s Internet Options Security tab’s Trusted Zone. Without more information it’s only a guess.


This is the error message and details I get when trying to “Update”:

When searching for available updates on the Update site, you receive the 0x8024402C error.
This error usually happens because we are unable to locate the correct proxy to access the internet or there is an invalid character in the proxy override settings.

  1. A misconfigured Proxy/Firewall can cause this problem. Double-check the Proxy/Firewall settings. Add the following urls to the exception list within your Firewall/Proxy:
    For help configuring Proxy/Firewall refer to documentation or contact the manufacturer.

  2. Remove invalid characters from the proxy exception list and then clear the proxy cache.

  3. Open Internet Explorer.

  4. On the Tools, select Internet Options.

  5. Click on the Connections tab.

  6. Click on the LAN Settings.

  7. Click on the Advanced button.

  8. Please delete any entry in the Exceptions section.
    Next, clear your proxy cache.

  9. Click on Start, and then click Run.

  10. Type cmd in the Open box to get a DOS prompt.

  11. Type proxycfg -d at the command prompt, and press Enter.

  12. Type net stop wuauserv at the command prompt, and press Enter.

  13. Type net start wuauserv at the command prompt, and press Enter.

  14. Now try the site again.

  15. Enable Web Browser automatic configuration within the ISA Firewall Client

  16. Open ISA Firewall Client.

  17. Click on Automatically detect ISA Server.

  18. Click on OK Button.

  19. Enable Automatically detect setting within Internet Explorer.

  20. Open Internet Explorer.

  21. On the Tools, select Internet Options.

  22. Click on the Connections tab.

  23. Click on the LAN Settings.

  24. Click on Automatically detect setting.

  25. Click on OK button.

  26. I don’t know how to do this.

  27. I’ve checked this and it doesn’t apply.

  28. I don’t know what this is.

  29. I don’t want to mess around with my connection settings, which haven’t caused me any problems until now.

What can I do?

I forgot to mention:
I have added the 3 Microsoft sites to my IE trusted zone, but I get the same “Update” error message when I try to update.

Have you tried to disable CFP? Will that do any difference?

You can also try to clear the log, then make another attempt to update. If it doesn’t work, it should be logged.


I’m having the same problem, on previous firewalls that I’ve had it’s been dead easy to add a url. Comodo seems to be over-complicated in this area? So if anyone has an answer I’d be grateful to know how to do it


I’ve just now had this problem and managed to solve it. Hope this solution will work for you all.

In my case I had to change some of Windows Services. First to set the Automatic Update service on “Automatic” - it wasn’t enough to plainly start it. The Event Log service and the Background Intelligent Transfer Service had to be started too (manually is fine).

Then I had to add the 3 following domains to the IE7 trusted sites list:

This is done through Tools → Internet Options → Security tab → Trusted Sites icon → Settings… button → now add the domains.
(Defense+ should let you know that Comodo is learning this behavior).

Close IE then try again to launch Windows Update - for me it worked :BNC