how do i use frostwire?

hi guys ! i use frostwire as my P2P , and it refuses to connect since i started using comodo ! can anyone give me details on how to “reconnect” ? i checked out other similar topics , but was unable to use them , as they were 4 utorrent and kceasy . thanx .

Hi and welcome,

Have you tried adding frostwire as a new trusted application? Also, see if CPF is blocking anything for frostwire in its logs (under the activity tab). You may want to post the logs here by right clicking on the logs and selecting ‘export html’.


i tried the 'trusted app" . is it supposed to give a conformation ? it did not . also , the first time i ran both together , comodo asked me abt it , n i said “allow always” . all it says under log is " inbound traffic violation" .

When you add a trusted app, CPF will not give a confirmation just allow the app to automatically connect.

Do you get the inbound traffic violation when you attempt to run frostwire?

i cant be too sure . there abt ten of those every minute even without frostwire .

Ok, have you checked in frostwire’s help manual or website on any thing you may need to do to allow a firewall to allow it to connect?

There is an article you may find useful on the frostwire forums [here]:


i read them , and they r all for xp firewalls . as u may hv noticed by now , i am a novice , and really need specific help . they say i shud try to switch off the firewall completely , but of course i don’t wanna do that ! (S) .

You certainly don’t want to turn off a firewall, it will leave you wide open to attack. Usually there is a section in the help files for P2P software on firewalls which refers to all firewalls - not just the xp firewall. If it is there can you post here, so we can try and see what rules (if any) you may need to add to CPF?


PS. Don’t worry about being a novice. We’re more than happy to help you as you need, we were all novices once. :wink:

Hey ayush, i just figured this stuff out myself and got it to work. Here are the steps:

  1. In frostwire, go to tools>options>+advanced>firewall config

  2. at the top, manually type in a random port #. i just typed a random 5-digit number like 58495. remember what you chose.

  3. at the bottom, choose UPNP.

  4. in comodo, go to security>application monitor>+add

  5. browse to ‘program files/frostwire/frostwire.exe’ and select that for the top entry.

  6. choose skip parent

  7. choose allow all activities, but leave the two options underneath uncheckmarked

  8. press ok

  9. in comodo still, on the left side, click network monitor

  10. add a rule with the following settings:

    action: allow
    protocol: tcp or udp
    direction: in
    source ip: any
    destination ip: zone
    zone: (your home network zone, you should have this set up when you installed comodo, if not, thats a whole other faq somewhere around here)
    source port: any
    destination port: 58495 (or whatever port you typed in frostwire) ok

frostwire can be running while you do all this, if you restore the window you will see that its connection is going up to excellent, and the little globe icon doesnt have the brick wall in front of it.

If it’s still not connecting, you might have a firewall in your switch or router or something like that. I had to forward the port through my router as well. its a pain the ass for all this protection, but its worth it. if so, visit and they will explain how to forward a port to your computer’s ip address. the port you’re trying to forward is that one that you chose manually in frostwire (tools>options>+advanced>firewall config, the number in the box at the top right). while you’re logged in to your router, you might as well set up port forwarding for all your other things that need it, like your torrent porgram, internet games, etc.

hope that helps, it worked for me.