How do I unintstall CSC

Reading the forum posts, I find that I’m not the only one experiencing the BSOD after booting my system and getting various error messages that have no type in them, just empty boxes. I have to reboot my system in the Safe Mode, and Restore to a date before the CSC install.
I find the CSC icon on my desktop (and an active APP). When I go to Control Panel to uninstall it under Add/Remove programs, CSC doesn’t show up. When I go to Start/Programs/Comodo/CSC/Remove & Repair, I get a Setup Wizard that wants me to install the program.
I would like to get the problem cleared up, but I don’t want to have to boot in the Safe Mode every time I turn on my computer.
Where do I go from here?


Please tell the version of COMODO System Cleaner you have installed. Thank you.

I have the same problem.
I have had horrendous problems with Comodo Antivirus and managed to uninstall after a couple of system crashes in the attempt.
I am now trying without success to uninstall Comodo System Cleaner, but like the poster I only get the option to install the darned thing again.

I can find no reference to any uninstall.exe file.
My version is 2.2.126408.3

I note that you advocate the download of MSICUU2.exe - but when I do this is says - “Windows script Host access is disabled - contact administrator”
I have no administrator and the PC is mine - so how do I progress with re-enabling this script thing?

HELP would be very, very much appreciated guys - urgently!

Having had numerous BSOD problems after installing/running CSC I have got rid of it (I think!) by :

  1. Re-boot into safemode, then delete C:\Windows\system32\drivers\CFRMD.sys
    (see;msg359412 )
  2. Re-boot into normal mode, then Start > Control Panel > Add/Remove Programmes > CSC > Remove
  3. Re-start system to complete removal when prompted

Then hit problem with computer very slow and lsass and cfp (comodo firewall) using lots of CPU, so back into safe mode, removed Comodo Firewall/Internet Security: Start > Control Panel > Add/Remove Programmes > CSC > Remove > Follow prompts, including reboot to complete removal.

Back in normal mode, checked Windows Firewall is on … while I ponder whether I can risk reinstalling CFW, it’s caused me major problems over the last week.

To enable Windows Script Host: Official Site | Norton™ - Antivirus & Anti-Malware Software .This may be of help.

Now you should be able to run msiuu2.exe. When done install CSC and uninstall it again. That should do the trick with a stalled uninstall.

Thanks Eric, for the link - I have looked at it though none the wiser - I am not a computer geek.
I see -
Enable (REG_DWORD)

“0” - disabled

“1” - enabled

But I would have no clue as to how to do whatever it is asking me to do…

Any clues?

The procedure I gave earlier has what I would describe as a low geek factor…

Points to note:

  1. AIUI it is CFRMD which is the actual duff bit causing problems (see related post) - which is why you get rid of it first - but if software (CSC, CIS ?) then tries to use it you’ll have a problem, so you need to get rid of that too…
  2. You may need to ‘show hidden files & folders’ to see it where it is to delete it.
  3. Again AIUI, if you’ve done a system restore to before you installed it, you’ve effectively taken it out of the system, and won’t see it in Add/Remove programmes - but have probably left a lot of files lying around that a ‘clean’ uninstall would have deleted.
  4. CSC appears to use the standard Microsoft MSI installer/uninstaller, not its own (unlike CIS).

Wondering if you’ve got yourself into a position where reinstalling might not be the best (or least bad) move, to get yourself to where you can uninstall it…

Well I got really fed up with this silly CSC program and the annoyance of not being able to get rid of it easily I tried another way.
I downloaded a free copy of Revo Uninstaller and used it’s “forced uninstall” feature.
Used the built in browse feature to find the Comodo System Cleaner exe file, loaded it in and pressed uninstall.
In seconds it found all files, dlls, registry items and it traced all installed files pertaining to the Comodo program - I then selected delete.

I checked out the system and I have no problems and there seems to be no vestige of the program anywhere that I can find.
Revo also does a System Restore point and a full Registry back up before any action, so has a fail safe.

Seems good to me.

I think the better way out is to open setup.exe from installation folder of CSC

c:\programfiles\comodo\Comodo System Cleaner

When you click on setup.exe, it will ask for remove / update.

Run update and it will download missing files if any, making the CSC installation complete. Then you can use revouninstaller or add/remove to remove the program, if you so require. Forced uninstall by revo may leave unnecessary traces. (In case of corrupt files, the remove feature of setup may not work).

BTW, today I had a pleasant surprise. My CSC icon had gone from the computer and when I tried to uninstall CSC, so that I can reinstall it, it reported error while validating, I tried the update feature and it downloaded the missing files. I ran CSC and found that now CSC scans for Opera 10 also, which I was missing earlier!