Hopefully V3 of comodo, fixes the Mirc DCC probs, MSN and Yahoo probs

Coz I’ve tried all of these.

And even tho u give access to all of them, Comodo still blocks some of their ports.

And I have a feeling the latest version of Comodo conflicts with the latest MSN Live Messenger.

Or its blocking some ports in MSN. I tried sending a file, MSN quit on me. The same thing has happened in Yahoo (the latest version).

~Edited by mod to remove empty spaces~


Can you please post a maximized screenshot of your network monitor rules and an extract from your firewall logs. I use MSN 7, 8, 9 and Live without a problem with CFP, including file transfers, video chat, etc.

Ewen :slight_smile:

I’ve removed MSN and Yahoo now, and only use Mirc.

Which I’m still having DCC probs (I’ve fixed DCCing on this PC (when I dial up) from this PC.

Its only when I try and DCC (when I’m going thru another PC, that can also dial up to the net).

As noted in the link below, I managed to add the TCP ports for DCC on the other PC.

It says access granted. BUT, DCC still doesnt work. When I try and DCC on this PC.

The snapshot is similar to this link https://forums.comodo.com/index.php/topic,8096.15.html

Altho, now its got 14 entries.

When MSN and Yahoo, were installed they did work, but Comodo’s log was still showing it was blocking some ports for both of them. Even tho u allow access for Mirc, Yahoo, and MSN, it doesnt do a good job of doing it. So, everything works. I spose its secure, BUT, IMO, its way to tight (the security).

I could do the same with Zonealarm, (i tried it) to see if that would work. Well it didnt ask for access to run Mirc, but at least it let me DCC files. Without doing anything else. For DCC to work.

~Edited by mod to remove empty spaces~

To setup CPF/mIRC for dcc follow these instructions.

Open mIRC, Then the Tools Menu, and the Options Submenu.

Under Category, choose Options (below connect and servers), Press the Advanced button.

It will pop up a dialog which allows you to assign a specific port range for your dcc connections. (I use a range of 10 ports).

You can then set Network control rules to allow TCP connections on this port range. You will need 2.

Allow TCP IN/OUT Source = Any : Destination = (PortRange)
Allow TCP IN/OUT Source = (Port Range) : Destination = Any.

Where the PortRange is the set of ports you assigned to DCC connections in mIRC.


Should those ports go on the main PC or this or both?

Are these rules safe to use ? I’m also running a router and can confirm that they work.

Whoohooo!! Something I know :BNC

mIRC is something I have used for many years. I now have Comodo because ZA ■■■■■■■ the pooch with their latest pile of nonsense…anyway…

You have a router. You also wish DCC on mIRC. You also have a software firewall. you also wish DCC on mIRC.

DCC…BAD. Nuf said? If you are going to open a HOLE into your system, then you had better keep track of it. The items you have in place were designed to block such things. Yes the rules do work for mIRC, however, do not fool yourself into thinking you are safe because you have router/and or software firewall…if you DCC you are opening up a hole into your system. If you are going to do that, be certain your lynksys or whatever router you are using is also configured for mIRC.
You can take a look at http://www.portforward.com/ for help. I have the rules in place, and have varied them from time to time, but knowing I have opened a hole in my system makes me feel silly about having a firewall at all :THNK

Umm, no I’m not on BB or cable, I’m on dialup, so I dont use a router.

I’m just using Comodo.

I know Comodo is the prob, coz without it, DCC works fine.

I have a Dynalink RTA1025W modem/router and it has a pre-configured rule for IRC. It port forwards the ports needed as shown here


I tried the rule posted above and it worked once but then i tried to download something else and it didn’t work. perhaps because the second download was in the port range 6660-6669 ?

i also tried the rule posted here https://forums.comodo.com/index.php/topic,1544.0.html without success. it states

If you are behind a router you must check "Bind sockets to IP address" and in that box you must put your routers external IP
My router is configured to obtain a dynamic external ip. So I have to temporarily disable Comodo for DCC with Mirc but I presumably remain protected by the hardware firewall. >:(

I modified the Scott B. rules so that the port range is now 1024 to 6669 and it works :SMLR
and since I only download from trusted users I hope this is safe.
It would be better to somehow restrict these rules just to Mirc and you also cannot narrow the port range like so: 1024-5000,6660-6669 as you can in Kerio 2.1.5
Is setting the Source IP and Destination IP to “any” risky?

Lastly, do you think that running Comodo adversely affects DCC download speeds or maybe I’m getting slow speeds because its Saturday.