Home Page Not Working, Set As Tabs - Give comodo.com on start

No matter what i do when dragon first runs it visits comodo.com instead of the New Tab page as set in settings, pressing the Home button takes you to the New Tabs…

This has only started happening today.

uninstalled and re-installed had no effect.

Dragon 2.1.1.0
No Plugins or Themes
Windows 7 x64
UAC enabled
System drive C:
Installed: C:\Program Files (x86)\Comodo\Dragon
User has Admin privileges
No other browser aside from IE installed

I have the same issue on WinXP.

Hi rabtok,
Thanks for reporting this bug.
There indeed is a bug in the most recent update as a workaround for now until it is solved try the following.
Go to Settings, On startup, Open a specific page or set of pages and enter the required URLs.
For New tab page enter dragon://newtab/ remove any others that you don’t require.
Kind regards.

thanks captain, that works.

You are welcome, let us hope in the next release that it is fixed. :slight_smile:

well, it was working… the problem has resurfaced a moment ago…still has startpage set as pages…

sorry meant dragon://newtab/ is set as home page, still jumps straight to comodo page.

Make sure your desired URLs are set in both Settings,
“On Startup” Open a specific page or set of pages
and “Appearance” Show Home button.