Home network blocked!?

Ok, so I’m trying to network 2 computers together (eventually 3). The problem is that I have Comodo fire installed on both, and when they are enabled, the network doesn’t work. I can’t see the other computers, I can’t print… I can’t do anything. But, when I turn the firewalls off, everything goes buttery smooth.

So, my question is, how do I make comodo firewall allow connections to other computers on my network?

The router is (netgear WNR834B)
Computer 1 is (wired, Static IP)
Computer 2 is (wireless, Static IP, has printer)

What exactly do I need to do to allow these to connect to each other?


Create network zone: + mask and + mask. Run stealth ports wizard, select first option, select this newly created zone.

Now your computers should connect to each other without problems. If something is not working still, look into the log for related block entries.

For your own security , I would hide some of your IP addres


I added both computers and the router with the subnet mask and did the wizard… but it still blocks everything.

"blocked - ICMP - - type(8) - 192.168.138 - Code(0)
“blocked - UDP - - 1031 - 192.168.138 - 137”

And aren’t these IPs just the internet network IPs that the router gives you? I didn’t think it would be a security issue if it was public… is it?

What does that mean?

Did you run stealth ports wizard on both computers making trusted same network zone?


Ok, it says svhost.exe and system are blocked… do I have to make a security policy for both or something?

I even made a global rule for the zone itself and it still doesn’t work. I’m about to give up on this stupid firewall…

Set firewall to custom policy, uncheck everything under firewall->advanced->attack detection settings (6 options) on both firewalls. Make sure there are default values “20” for tcp, udp and icmp flood. Does it make any difference?

If no, post a screenshot of blocked svhost.exe and system events on one computer (1 or 2).

I’m not sure if it matters, but I’m using Comodo Firewall Professional. I didn’t see anything to uncheck in Attack Detection settings, but everything is already at 20.

Still doesn’t work.

Tried unchecking “Do protocol Analysis” as well (it was the only one left) and that didn’t work either…

Now, I’ve fiddled so much, I’m worried it won’t block things it should be blocking… aside from legitimate connections…

Export your config, delete global rules on both firewalls, delete “windows operating system”, “system”, “svchost.exe”, “windows updater applications”, group “all applications” from Application rules (on both firewalls).

Set both firewalls to training mode. Connect for a couple of times. Then set both to custom policy and try to connect.

On this point did problem disappear?