HIPS problem with Firefox Flash and Silverlight plugins

Was using CIS 8 (not the last update, the one before - all attempts to install the last CIS 8 version created unusable computer that BSOD on clicking in the login screen password field, so rolled back to previous CIS 8 version). Everything OK.

Exported config, installed CIS 10, imported previously saved config and switched to it.

Two problems. First caused by Viruscope, solved by disabling viruscope, leaving that for now.

Second problem appears to be caused by HIPS. Don’t understand HIPS enough to fix, but not happy to just leave HIPS off.

Problem when HIPS is enabled to Safe Mode:

When browsing with Firefox (not using sandbox - don’t use that - just normal Firefox browsing), every time I go to open a page that requires Flash or Silverlight, page starts to load but then ‘hangs’ for minimum a minute, usually several minutes, completely locking up Firefox while ‘wait’ icon is twirling, and intermittent appearances of the ‘plugin not responding, wait for response or stop plugin’ dialogue, minimum 3 appearances (with me clicking to wait each time), so far up to about 5 times before the page finally finishes loading and Firefox starts responding again. Previously with CIS 8, and with CIS 10 same config except with HIPS disabled, the same pages load in seconds, Flash Player or Silverlight ready to go with no hang, no plugin not responding messages. Makes browsing unbaerably slow with all the multi-minute waits every flash or silverlight page.

As I say, disabling HIPS clears the problem. But there’s nothing in the HIPS log, no Comodo windows asking for a permission or anything during the long delay for the plugins to load/start/whatever the hild up is. I could understand if HIPS just blocked the Flash and Silverlight plugins, but I don’t understand why it is just delaying for several minutes the start of these Firefox plugins with no logs, no dialogues to indicate what HIPS is doing - and doing wrong - that i can correct.

Any suggestion of a config change I can make to allow me to enable HIPS Safe Mode without it having this effect on the use of the Firefox Flash and Silverlight plugins (as was the case in CIS 8) would be much appreciated.

(Windows 7 Home Premium SP1 64 bit; Firefox 50.1.0. latest Flash and Silverlight plugin versions)

Are you using the x32 or x64 bit version of firefox. I haven’t noticed any issues.

The x32 bit Firefox.

With CIS 10 and the HIPS on Safe Mode, the massive delay for pages with Flash or Silverlight content on to open (totally locking Firefox up, and multiple ‘The Plugin is not responding’ messages) makes browsing effectively impossible. To browse I currently have to disable HIPS completely, which I’m not very happy about. Perhaps changing one of the HIPS settings would help, but I don’t understand them, or the other implications of altering them if changing one would help.

Sounds almost like a corrupt HIPS configuration profile. I recently ran into this - had AVG 2016 Ultimate installed but all components deactivated - and the installation of CIS v10 was horked completely when HIPS was enabled.

The way I fixed it was to activate the default Proactive configuration profile, exported it, and then imported it as My Proactive and then activated that. Unfortunately the several hours I spent clicking on allow this and that was lost. :cry:

Thanks, but there have been developments.

First, the initial connection to HIPS disappeared. I started having the pages-with-flash-or-silverlight taking minutes to load problems even with HIPS off, and could only stop it by disabling multiple CIS 10 components (nothing in logs), with it changing each session which had to be disabled, up to one session when I had to disable every CIS 10 component.

Second, the other problem I mentioned as being solved by disabling Viruscope stopped being ‘cured’ by that - the problem being the computer starting/re-starting only with a basic theme with the Aero themes disabled and the ability to change themes being ‘unavailable’.

In the end I gave up and uninstalled CIS, picked another antivirus program, installed that and posted in the thread here for people to say why they had uninstalled CIS.

But that wasn’t the end of the story, as I missed all the things CIS is supposed to do which my ‘new’ AV choice (Avira) didn’t. I got to thinking about the desktop no-Aero-theme problem (and another annoying problem I’ve had all the time through CIS 8 versions and still with CIS10 - if after start/re-start I logged in promptly CIS wouldn’t start, there’d eventually be an error message with the offered diagnostic never finding a problem, and then I had to start CIS manually; or alternatively I could wait about three minutes at the Windows log-on screen before logging on, and then CIS would succeed automatically). A theory as to the cause of these problems and a possible work around (if my theory was right) occurred to me if I could find some software somewhere to do something I’d never seen (or looked for) a program for, but I figured there had to be some such program somewhere. And there was - freeware, too. Uninstalled Avira, reinstalled CIS 10 - all three problems reappearing as expected - installed new program, configured new program to test me theory re-started computer and …

… the two CIS problems I’d hopped it would fix were indeed fixed. Computer, with CIS 10 and all modules enabled now starting/re-starting with Aero theme as normal, theme manager working as normal, CIS 10 - for my first time with CIS since i started using it a couple of years ago - starting properly withoutmy waiting 3 minutes at the log-on screen before logging on or having to manually start it after everything else that autostarts at logon.

Which was great, a viable workaround to those two problems. But - quite unexpectedly - so far it appears that it has also cleared the flash-or-silverlight-on-page load several minute delay I started this thread about. I can’t think why - that wasn’t part of my theory; i was expecting to have to separately consider the flash-silverlight load delay problem if I had actually cleared the startup-and-theme problems. But so far all 3 issues I had with CIS 10 appear to have been fixed by my theorised solution to the first two.

It’s been less than 24 hours, though, so I need to run a bit longer to be convinced all 3 problems - and especially the flash-silverlight load time one - are truly fixed. As and when I’m sure that any/all problems are truly fixed I will post about it, with instructions, in case it helps someone else who has any/all of these problems.