HIPS blocks command chkdsk /f

Windows 7 Pro x64
HIPS blocks command under cmd chkdsk / f
Require disable Disk control
Bug or voluntary protection?

[attachment deleted by admin]

I can replicate this issue as well, I’ll create a bug report for it.

Edit: Bug report created, 1470.

Thank Sanya,
Report forum french (I am moderator)

THANK YOU!!! This was driving me insane!

I couldn’t run “chkdsk [drive:] /F”, on ANY drive, even from an elevated command prompt, without getting “Access Denied”. I even went so far as to enable the “hidden” Administrator account in Windows 7 and couldn’t make it work there either. It would only work if I restarted in Safe Mode.

However!!! If I opened Windows Explorer, right-clicked a drive, and chose “Tools/Check for errors” (with “fix” selected), THAT worked. Only the command-prompt chkdsk was denied me.

But once I (finally) thought to disable my security software, and turned off Comodo’s HIPS, THEN it worked again.

Why would it block chkdsk but not the Windows Explorer GUI?

Hi ZorKas,

As I understand it from using Google Translate on the French forum, this issue is fixed for you in 8.2.4508?

For me this is still not working in 8.2.4508, could you try with a clean proactive config? I just want to know if it’s just me with the issue now…

Hi Guys,

Thank you for the feedback. Problem will be fixed with the next Hotfix release .

For your kind information


Thank you Buket, I’m going to send you a PM soon with a scenario and an application that I want you to test if possible, potentially devastating bug or just my installation being corrupt.