HIPS blocking applications causing system freezing

I’m experiencing very similar issue on my Lenovo Legion 5 (Ryzen 5, RTX 2060, Windows 10). It appears the HIPS is preventing the application from accesing something that is needed. And instead of the aplication crashing the whole system just freezes. I can stil move a mouse but the system is not responding to any clicks or even to keyboard input. The only solution is to reboot the laptop. The issue is most noticable on the applications using Unity Engine or Java.

If i turn the HIPS off the issue is gone, but i don’t like runing my laptop without HIPS.

Also if i try use the inbuild sandbox for some programs i’m unable to use the mouse or keyboard in the sandboxed program. The passthru of the HID is having some issues.

You could try to set HIPS to “Training Mode” just before starting the system freezing applications and let HIPS learn and auto create rules for those applications for a while. When done you can set HIPS mode back to previous mode.
Just a suggestion…

It’s a solution but I don’t like the option to let the HIPS create all the rules, i like to be in control so i can decide if the application should have acces to the registry or to the system files. The automatic detection could cause some unwanted rules to be created.

Also the main issue is the fact that same instalation of CIS on other laptop is not having this issues. It’s also a Windows 10 Lenovo Laptop but it don’t have a dedicated GPU.

The potential issue could be some HIPS problems with accesing a dedicated GPU but the driver update or even clean install did not solved that. Is there en option to disable HIPS for a GPU process or for the Windows 10 Desktop Window Manager (dwm.exe) ?

Would disabling HIPS for those applications / processes not be the same as adding HIPS rules for those applications / processes set to Ruleset “Windows System Application”?
Disabling HIPS means allow everything and that’s what Ruleset “Windows System Application” is designed for.

The problem is the other application trying to acces a Windows System Application. not Windows System Application itself. I think it’s not a feasable option to set a Unity Engine game or Java .jar file to be a “Windows System Application” I like them to be as “Restricted” so they can acces only what i allow them (usualy access to their own folder or the other parts of the same applications). But when i restrict them from accesing a COM Device the system freezes. And sometimes the prompt did not even show and the OS freezes without any notification.

It’s just confusing why this happens on a Lenovo laptop with dedicated GPU and not on other laptop with a integrated GPU :frowning:

Hi LandCat001,

Sorry for the trouble, we will reach you through private message to get required logs.