High CPU usage by CFP.exe when launching internet programs

I’ve been using Comodo Firewall for a while no and have been happy with it until about month or two ago. Every time I launched Firefox my processor started going crazy, FF lagged (“Not Responding”) for about a minute and then was fine. Thought it was FF at first so I completely uninstalled and reinstalled with no add-ons to no avail. Then I decided to watch task manager while launching FF and was surprised to find CFP.exe jumping to over 56% of CPU and 3-4k memory – and I’m running a Core 2 Duo T7500 at 2.2Ghz. Before launching and while FF is running, cfp.exe is at 0% and the same about 3-4k of memory. I ran “Diagnostics” from the miscellaneous tab of Comodo, but it says everything is OK.

I’ve noticed the same problem when launching Pidgin, my Cisco VPN client, or basically anything else that tries to connect to the internet for the first time as launching – it all just freezes upon launch. I vaguely remember installing a FF update right before this started, but have done new updates since then and all of my other programs are up to date. So the FF update shouldn’t have an effect on Pidgin or the VPN client.

Any ideas on whats wrong or how to solve this? The only thing I can think of, and haven’t done yet, is to fully uninstall, clear all files, and then reinstall Comodo.


what version of comodo are you running? I know there was a problem with the early 3.8 version with high cpu usage but that got fixed.

Comodo is fully updated to version 3.9.95478.509 although my full install was version 3.8.64739.471 after I got a new hard drive. But I had no problems with it right after I did that install of version 3.8

Also, right now I’m listening to Pandora and its killing my system. CFP.exe is routinely at ~50% right now, with occasional short drops (my cpu usage graph history has processor 1 being destroyed at nearly 100% and processor 2 varying more like normal). Now I know that I read somewhere else about problems with Comodo and pandora, but again, this is relatively new problem for me–its not always been this way.

cfp.exe 48CPU 6,044K and rising
firefox.exe 0-5CPU 235,224K (this happens when streaming, had it in the past so this isn’t the cause of the slowdown)

I have an Intel Core 2 Duo at 2.2Ghz with 2GB ram and all my powersaving features off, so my system should not be this affected…


I would recommend a complete clean uninstall and a clean reinstall. Something must have messed up.

Copy that. Please do a clean install and follow the following steps to be sure all traces of CIS are gone.
Start with exporting your configuration to a folder that is not part of the Comodo folder under Program Files. This way you can restore your configuration after the reinstall.

Uninstall CIS and reboot. Then run [url=https://forums.comodo.com/comodo_system_cleaner_fileregistryprivacy_cleaner/comodo_system_cleaner_116494436_released-t37631.0.html]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See: https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_info-t17220.0.html;msg119226#msg119226

Now you should be good to go

Yea I followed pretty close to that format. I found a similar set of instructions here (https://forums.comodo.com/empty-t38378.0.html) from you EricH actually. I ran the uninstall through Revo (my preferred uninstaller), deleted the files and then went through the registry. I didn’t run CIS because it found a lot of things in my registry and I didn’t have the time to pick my way through them all to find out what exactly was Comodo and what was not (yea I know I have to do this, but I needed my computer back and operational ASAP). So far evertyhing is running great, although I have not actually imported my old settings because I haven’t run into any problems without it, and I wasn’t completlely happy with some of my settings and wanted to see how a clean version reacts to my computer. Thanks again for the help, though I am still perplexed as to what actually went wrong…