Heuristic command-line analysis showing HIPS alert

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes. Always.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Enable HIPS
2: Enable HIPS setting ‘Do heuristic command-line analysis for certain application’
3: Click ‘certain application’ and enable \cmd.exe (Default enabled)
4: Run any software using cmd.exe command line. (I’m using ‘GeekBuddy URL link’ and ‘War Thunder Launcher’)
5: Shows HIPS alert and some C_cmd.exe_
.bat file created in ‘C:\ProgramData\Comodo\Cis\tempscrpt’
One or two sentences explaining what actually happened:
Shows HIPS alert
One or two sentences explaining what you expected to happen:
Not showing HIPS alert
If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
do heuristic analysis without external *.bat file.

Exact CIS version & configuration:
Default configuration
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS default level (Safe)
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 RS1 x64
UAC Enabled (Default)
Member of Administrators
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

Did you change rating of mentioned applications to “trusted” ?


Same explanation :

Thank you.