Help!!! Vista Not Loading

I ran CSC (Registry Cleaner) prior to installing CIS again but unfortunately, I’m still getting the same error :'(. Installing another firewall is an option now but I would prefer to fix this problem and carry on using CIS if possibble.


If you want to give it another try, try uninstalling CIS, rebooting and then use this clean up tool.

When done with the clean up do as follows. We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs and Comodo are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs or CIS click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.


Finally managed to get CIS fully working ;D. Ended up having to manually install “COMODO Internet Security Firewall Driver” network service.

Thanks to everyone who replied with help and advice :-TU.