Help!!! Vista Not Loading


I downloaded the latest version of CIS (… .522) for Vista and upon restart, logged in and CIS reported that the firewall wasn’t functioning. I ran the program update and was told there was an update available. Upon restarting, Vista now reports that it cannot startup and I am unable to use a previous restore point (as there isn’t one). In fact, I can now only get to a command prompt. Please help!!!


Edit: Btw, this laptop was using IPv6. Is CIS compatible with IPv6?

No…CIS doesn’t support IPv6…
CIS v4 will support IPv6.

Vista problem: try this.
1.boot as Safe mode.
2.uninstall CIS.

Hi Creasy

From memory, I was presented with normal startup and another option (possibly safe mode). On selecting other option, it goes into another program to repair, re-install, troubleshoot problems. Repair didn’t work and troubleshoot took me to the command line.

Sorry for sounding so vague but this isn’t my laptop and I’m not familiar with Vista yet (still using XP myself).


EDIT: Other option is “Launch Startup Repair (recommended)”

Ok, have laptop with me now :).

On starting laptop, I am presented with “Windows Error Recovery” and the options are:

  1. Launch Startup Repair (recommended)
  2. Start Windows Normally

Selecting “Start Windows Normally”, BSOD quickly and then reboots (too quick to identify STOP error)
Selecting “Launch Startup Repair” loads “The Tech Guys 3.0” interface

From this interface (TTG3), I can select:-

  1. Start Microsoft Windows Repair Environment (which didn’t fix anything)
  2. Re-install Windows (would prefer not to use this just yet)
  3. Advanced Options (Chkdsk and command prompt)
  4. Exit and Restart computer

Any ideas?


when booting your pc keep hitting F8, this will bring you in a menu, choose for safe mode with networking and the pc will start in safe mode, log in to your account and uninstall CIS. That should do the trick.

Hi DaRtH VaDeR

I did manage to get to this menu (don’t know how) and select “Safe Mode”. However, soon after it BSOD and reboots. Is “Safe Mode with Networking” any different? I don’t think I can access WIndows GUI at all and changes will need to be made from the command line :o.


When you have a Vista installation DVD, borrow one when needed, boot from the DVD and choose repair. Then let is do System Restore and see if that helps.

Should I backup any user data prior to repair? As it’s not my laptop, I wouldn’t want to loose anything.



As I’m sure CIS is at fault, is it not possible to remove (or rename) any CIS files (from command line) which would then allow Vista to boot properly? Could that be an option?


Having a backup is always a good thing. I am unsure if there are files that can be deleted to prevent CIS from loading, but I believe that Safe Mode bypasses all CIS modules.

Your best bet is to get a Vista DVD and let System Restore do its stuff.



I’ve managed to stop the laptop rebooting after the BSOD and the error I’m getting is:-


STOP: 0x0000000A

Unfortunately, the owner doesn’t have a recovery CD plus I can’t boot either of my Parted Magic CD’s to be able to backup any data. :o


This stop code is usually related to a problem with a driver. Is there recently installed a new device or a new driver?

When a new device was installed make sure to get the latest driver from the maker of the device.

When recently a new driver was installed install the previous version.

I’m sure the problem lies with Comodo’s driver as I originally looked at this laptop because there was no connectivity (wired or wireless). Un-installing Comodo’s system driver (can’t remember exact name) when CIS had previously been un-installed (not by me) corrected this problem.

I then downloaded and installed CIS *.522 version but reported the firewall as not functioning. Next, I ran update within CIS which installed a newer version and on reboot, that was my lot BSOD :frowning:

If CIS can be un-installed manually (from the command line) that might be my only option.


Just to clarify, any Vista install disks will do the trick. It does not have to be specific to the laptop you are trying to get back to life. You can download iso’s if need be. (it is not illegal to download or copy the media. it is illegal to use the OS without the license)

For backing up the data, here is a link to some freeware that may help.


Hi bulgroz

My brother has got a Vista disk so I can borrow his if need be. Regarding backing up data, I’ll use G4L which I’ve found very usefull. Will need to use an external DVD drive as the built in one doesn’t seem to be working.


EDIT: Btw, thanks everyone for the help and suggestions :-TU.

While troubleshooting also consider the following as a possible contribution to the problem with the CIS driver.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are noauto starts from your previous security programs download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

Hi EricJH

Unfortunately, I can’t get into Windows at all to troubleshoot :frowning: (only command line). Egemen has kindly offered some suggestions so I will try these when I return to work on Monday. Hopefully I will be able to get Vista back up and running but if this doesn’t work and without any installation medium, I may go down the Linux route (either Kubuntu or Ubuntu).


Keep us posted on what egemen suggested and if it worked or not.


I deleted inspect.sys, cmdhlp.sys, cmdagent.sys (within Windows\System32\Drivers) and guard32.dll (Windows\System32) as suggested by Egemen and Vista was then able to load and I could logon :-TU. However, I am now getting a “The network firewall is not functioning properly” error upon logging on.

Not sure how serious this is or how easy it is to fix but I’m very happy the OS is loading now ;D.


I see. By taking out these core files your Firewall is not running anymore. It helped you to get in Vista. Did he offer some more tips or advice.

With these files disabled you either need to uninstall Comodo and install another firewall or reinstall Comodo…