Help - Urgent - can't run anything

XP Pro SP2 and Avast! - about all.

Installed CFP yesterday; running OK and apps. quicker to open than with OA.

Didn’t change v. much: started with Clean PC and learning in Defense+; after most of the learning seemed to be done, changed to Learning with Safe Mode (apologies if the terms aren’t correct, but I can’t get at CFP!)>
One uncommon app. - Quicken - CFP didn’t know about (it’s several years old) came up so I selected it as a single. app., ticked Remember and OK.

From then on some things that had been OK wouldn’t open, then got to the pont where I couldn’t even shut down - didn’t have permission!

Tried Last Known Good - er, no good.
Tried Safe Mode - same.

Booted fron a Linux Live CD - couldn’t change anything on the Windows drives.

Now I’m on another HD, changed the names of all the Comodo folders that I could see, moved them to another partition (couldn’t find a way to do anything to Services or Reg.).

Tried again with the ‘CFP’ HDD - same problem, no permission to do anything.

Please, is there any way out of this? I can’t uninstall CPF from the secondary HDD and can’t run that HDD as primary.

Any suggestions gratefully received.


You should be able to uninstall cfp from Safe Mode, if that is failing you may have another, more serious problem.

Thanks Toggie. Perhaps I’ll have another go. As I said, everything is blocked even after moving the folders.

Well, managed to get in to Safe Mode, remove CFP :frowning: and as many Reg entries as I could find.

Now reboots and I can do things BUT it’s in a form of Safe Mode - lots of things loaded but some not - and I can’t get back in to the choices of modes when I reboot.

Phew - managed to get back to Last Known Good and now it works.

Now on OA again; will try CFP when it might not bork me 'pooter!

I had the same experience today, and it actually fried my system to the point that System Restore could not function. I had to restore the registry manually from the command line.

I was able to repeat the process a couple of times (for the sake of investigation) by telling Defense+ to treat an application as an “isolated instance” or as “part of the system”.

For the record, there was only one file which actually needed to be restored, which was “C:\windows\system32\config\system”. If you (or any one) needs to know how to restore this from the command line, I’d be happy to explain.

I was thinking of filing a bug report on this, but I am not really sure of the best way to explain/document it.


Well done! I did it the clumsy way: Safe Mode, uninstall, struggle to get out of some form of semisafemode thing, install OA. Then cloned the HD again!

Please, simple instructions for Command Line repair would be useful - better than all the faf I’ve just had!

It seemed reasonable to say that Quicken was ‘an “isolated instance” or as “part of the system”.’ and, for a time, there was no problem. It was when I tried to start a vital app. (Solitaire) that I found out that I couldn’t do anything.

Does the FW work well without Defense+?

Hey Giraffe,

The way I fixed it was kind of clumsy as well, but it allowed the computer to function without uninstalling. I actually wished I would’ve known Comodo was the cause (it took me forever to figure that out :-P).

I actually don’t know how Comodo is without Defense+, I just recently started using it after receiving a recommendation somewhere online. I like it, and would like to keep using it, but we’ll see if this gets resolved.

In short, you need to copy _REGISTRY_MACHINE_SYSTEM in the snapshot folder of a restore point to C:\windows\system32\config\system

Here are the steps I took to restore the computer. The first 7 are just to find out the name of the files we are working with. (All commands are in braces [])

  1. Insert Windows XP install CD
  2. At the screen where you chose to install or use a recovery console, press ‘R’ to use the console.
  3. Type [cd C:“System Volume Information”] to go to the system restore directory
  4. There type [dir] and it should have a file with a really long name in the form of “_restore{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}” or something.
  5. Switch to this directory using [cd _restore{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}]
  6. Type [dir] to list all of the available restore points, they will be in the form of “RPXXX”. Look for one with a date before the problem began.
  7. Switch to that snapshot directory of that restore point with [cd RPXXX\snapshot]

Now we have the file we are going to restore from, so lets make a backup of the one we are restoring to.

  1. To rename your config/system file in case we need it back, type [ren C:\windows\system32\config\system C:\windows\system32\config\system.bak]
  2. Now let’s restore the back up with [copy _REGISTRY_MACHINE_SYSTEM C:\windows\system32\config\system]
  3. Type [exit] to reboot, and don’t be worried if you keyboard and mouse don’t work at first, it took about 2 minutes before it finished reinstalling drivers for mine.

Kind of a pain in the A**, but a really good technique to know none-the-less. You could hypothetically do this in one line if you just knew all the files you had to work with so it may not be a bad idea to write down those ridiculously long folder names

Thank you! I’m useless with c/l stuff and would never have figured out how to do this.
Not sure that my XP CD will function in this way - it’s a bit peculiar at times :wink:

Anyway, printed and saved as PDF.

Haha yea, it’s a pretty hairy fix.
I sure hope they sort out the bug which causes this. No fun to have to deal with.