Help, upgrade/re-install fails because of CIS leftovers in registry


Here is my big problem. I’ve been a Comodo users for years, until approx. 3 months ago when I tried to completely uninstall CIS to do a clean re-install. Re-installation failed because of CIS leftovers that are kept in registry. They just can’t be remove ( protected?) and, for some reason, prevent the installation of Comodo, either Firewall or CIS.

I went trough all forums, here and elsewhere, to try and find a solution/tip to get rid of these leftovers and be able to re-install Comodo. Unfortunately, I found nothing which effectively works. This post is a sort of desperate last try.

Here is attached a partial screenshot of items left in registry.

Any help would very much appreciated.

[attachment deleted by admin]

Hi Hurzx. With Caution you could right click items in question open permissions then tick full control allow, apply,ok, then try deleting them. If this doesn’t remedy your problem their could be more to it than that stopping you though, have you the correct installer 32bit or 64 bit? Also at what point does installation fail? Good luck and kind regards.
Edit-added word

May I assume you’ve already tried the Clean-up tool for Comodo Internet Security?

If so, as captainsticks suggests, you’ll have to do things manually, however, to delete registry entries, you will need to have Administrative rights on the computer. You may also find that even with Administrative rights, you still cannot remove some entries.

If you come across a stubborn entry that refuses to be deleted ‘normally’ you’ll have to take ownership of the entry before it can be deleted. (See image)

[attachment deleted by admin]

Thank you very much to both of you for your help.

Unfortunately I already tried all that.

Sure, I had tried Comodo clean-up tool, with no more success.
I had also tried to get control over registry keys by amending permissions although I’m already the owner of this pc with admin rights. I managed to cancell only one key, but it did not work for the 16 other. I got an answer that it’s not possible.
Just a point. I read in another thread that a moderator called “global” was working on improvements of a batch CIS removal tool. Do you know if a new version has been released ? and where it is ?

Thxs again for your help.

There is another way of deleting those Legacy driver keys.

You need to start Device Manager and let it show hidden devices. Open a command prompt and type in the following two commands (push enter after each command):
set devmgr_show_nonpresent_devices=1
start devmgmt.msc

Now device manager will start. Under View choose : Show hidden devices".

You will find the CIS related drivers under Non Universal Plug and Play drivers. Select the drivers one by one -->right click → choose uninstall → don’t reboot until you are done. The drivers to uninstall are:
Comodo Internet Security Eradication Driver
Comodo Firewall Pro Sandbox Driver
Comodo Firewall Pro Helper Driver

Does that do the trick for you?

Thank you for your reply EricJH,

Yes, I had already done that also. However I found only one driver under Plug’nPlay, Comodo Internet Security Driver that I cancelled. That’s one of the issue that I don’t understand. When I run Regseeker it finds several drivers but I can’t see them in Device Manager hidden files…

That’s really a nightmare.

There is also a problem with Windows Installer apparently.

Hi . Thanks Eric and Radaghast for your help here.
To Hurzx. Sorry to see all our suggestions failing.
Is their anything out of the ordinary with your setup?
Also are downloading the installer before attempting to run or running direct?
If the later I would try save to download (est 34MB for 32bit or 36MB for 64bit), and only execute after it has downloaded? I find if not done this way all it takes is a small cliche in the internet connection to fail.
Sorry our suggestions have failed so far. Hope you find a solution. Kind regards.
Edit- Download Antivirus for Mac | Free Antivirus Software for Mac

Here is another strategy to directly delete the Legacy keys in the registry: How to delete 'Legacy' registry entries? | Wilders Security Forums .

It is uses psexec to start Regedit with elevated rights that allows to delete the Legacy keys.

You could also investigate RegDelNull

@ EricJH

Thxs for your help.

PsExec is very powerfull and so a little bit dangerous. Anyway I took the risk and I’m glad to have deleted a few more keys. I’m now left with a few ones which seems impossible to delete until now as they keep reappearing…