Help plz: v3.9 crashing system on install, v3.5 installing normally

Had my first jeepers creepers experience with comodo today. :frowning:

Downloaded v3.9 and tried installing it (choosing only the Firewall to install). The malware scan went fine.
Problem started after the mandatory system restart. The black XP logo screen came up fine after restart, then mouse pointer shows on screen for a split-second and then the system crashes and restarts.

Tried several times, system crashes at the same point in booting each time. Went into Safe mode, then into Admin> Services and disabled Avast antivirus, and SnoopFree services from starting. Retried again but no effect.

On trying “Last Known Good Configuration”, system starts but only Cfp.exe loads, not cmdagent.exe
Could not get cmdagent to load even on directly trying from the program folder.

The Comodo screen shows for a long time (several minutes) that comodo is trying to initialize… then came up with “Your network firewall has been setup incorrectly. Run diagnostics”. On doing as stated, again system restart is asked for, and again the same loop of crashing starts.

Tried for hours and hours… Finally gave up, uninstalled clean. Then tried reinstalling back v3.5, and it installs beautifully! No probs at all, and even with no need to disable Avast.

Can someone please help with what could be causing the problem? I have 256mb RAM, could that be a fait accompli?
{Apologies for long post, i have tried to list the sequence of events.}

Hi cimmind,

Please Uninstall Snoop Free. It is Not compatible.

Everything should be alright then with your new install of 3.9


Hi, thanks for the reply…

Is it a new compatibility issue? What i mean is that i am being able to install v 3.5 perfectly without needing to disable anything. then, does that mean SnoopFree is incompatible with the new version only?

I did disable snoopfreesvc service from admin, but i do notice that SnoopFree has a “snopfree.sys” (It is spelled snop!) driver, that is loaded even in the Safe mode.

Sorry for my asking, but i just spent four hours trying to install v3.9. Would really like to identify problem before trying again.

Snoop Free is for sure Not compatible.

It was confirmed by Egemen, CIS lead developer.

Quote from Egemen - “This is related to SnoopFree. It is attacking and undoing cmdguard.sys hooks. Please uninstall it before using CIS.”

Quote from Egemen - “We will be including it in our black list as it attacks our program and does not differentiate between security software and a rootkit.”

You should be OK once you uninstall it.

Bad :slight_smile:


I will try that that and get back to you on how it went… But not today. After four hours of grappling and being back to square one (v3.5 which i already had, before i went fishing for 3.9) do not feel like taking the risk again on same day!

Can you tell
Just one clarification… Do you mean to say that i cannot install SnoopFree even AFTER putting on 3.9? I do like the little program.

Yes, don’t reinstall it. Something will just break again.

CIS with D+ is far more than Snoop Free anyway.

Bad :wink:

Ok, got it. Will have to sacrifice little snoopdogg! :slight_smile:

By the way, i managed to locate the quote from Egemen, i have also posted a query (on the same thread) to him regarding whether the incompatibility issue is specific to v3.9 only.


Yes the problem appears to have come since 3.9.
Big changes under the hood from 3.5.

Need some proof… you’re living it ;D

Keep us posted.

Later Bad

PS. - TIP - Do fresh install, not upgrade from 3.5 (due to the big changes) a fresh install is HIGHLY recommended.


That did the trick!
Thanks for giving the tip about the incompatibility with snoopfree.

Bad frogger, you are Good! :wink: