helllo all! a little help?

Hello everyone. I just installed SE and went throught the steps to get my certificate during installation…but when I go to my email to collect I have a problem…

The link takes me to a page where I need to reload and click “allow” when the security popup appears. Well, it never appears. At first the page told me I had to use IE (I was originally using FireFox) so I opened up my IE and tried it but still this message with no security popup/warning/message/anything…

Collection of Secure Email Certificate

Attempting to collect and install your Free Certificate…

You need to authorize the “Microsoft Certificate Enrollment Control” to install your new Certificate:
Click here to reload this webpage, then…
When you see a Security Warning popup, click Yes to install the “Microsoft Certificate Enrollment Control”.

I’ve tried this with popups off, comodo added to my trusted dites, and with protection mode off. Still nothing. the page just sits there staring back at me. Am i supposed to be authorizing the control forst somehow and then reloading the page?

Thanks in advance

ok, i figured it out. installed my certificate and have SE running now …but Comodo says Comodo is a suspicious sender??

Hi ajaycee,

Did you change any of the default settings, set some alert slider to higher levels perhaps ?
And those emails are send by an other address then the one that shows up in the “From” Field.
If you check the email headers you’ll probably notice it’s send via a mass mailing system.

We have the same issues with our corporate spam filters triggering on these emailings, also hotmail marks them as “unsecure” every now and then…

First time logged on, and I don’t have a clue to the correct procedure!!
here goes. I have to disable “network defense” to receive any e-mails. Only started to play up about 3 mths. ago. Please any help

Hello Davidid,

From your post i assume you are having trouble with Comodo Internet Security blocking you incoming email traffic ?

Can you check the Firewall’s (FW, View Firewall Events) logging and see if it blocks anything regarding ports 110 or 143 ? Those are normally used to retrieve emails from servers.

You can also check to see if there is a block rule for your email application on your network policy (FW, Advanced, Network Security Policy) now look-up the email application you are using and see if there are any “block” rules for it.

How did you manage to get the certificate installed? I have exactly the same problem as you describe here, but not idea for a solution…