Firewall bugs. 4.0.664 & 4.0.679 & 4.0.716 & 4.0.742 & 4.0.779 (held errors)

Stuffs: Vista Home Premium SP2 32 bit, admin account, UAC disabled,
V4 Firewall version with Proactive, Safe, Safe, Enabled.

1.) Main screen. Spelling error. End of the sentence missing the dot.

2.) “Firewall Behavior Settings” > Safe Mode. Mark the check-box “Create rules for…”, “OK”,
right click on Comodo icon at Win sys tray, disabled the Firewall Security Level, next set back
to Safe Mode. Go again to “Firewall Behavior Settings”, and the check-box will empty!

[attachment deleted by admin]