I’m having trouble sharing files using Hamachi along side with CPF.
It only works when I turn off the Network Monitor.
This is what I tried :

Made a Zone : Hamachi Network Interface /

Allow IP In from Zone : [Hamachi Network Interface /] to IP Any where IPPROTO is Any

Allow IP OUT from IP [Any] to IP Zone : [Hamachi Network Interface /] where IPPROTO is Any.

Anybody got an idea ?


Hi mr.shaky

I suspect the answer is probably in CPFs Log. But, perhaps the following 2 topics will help…

[url=https://forums.comodo.com/index.php/topic,788.0.html]Hamachi fails after installing CPF[/url]
[url=https://forums.comodo.com/index.php/topic,1578.0.html]Fake or malformed UDP packet, Hamachi[/url]

Thanks for the tips Kail.
The mate with whom I am trying this is doing major surgery on his computer so I cant check it right away. But I ll get back to ya.

This worked for me:

IP In Source:5.x.x.x Destination: Any
TCP/UPD in Source:5.x.x.x Destination: Any
IP Out Source: Any Destination: Any
TCP/UDP Out Source: Any Destination: Any

where 5.x.x.x is the IP of the peer you are trying to allow communications for.

Just in case, you wanted to use Remote Desktop, you will have to disable the option to block fragmented IP datagrams and possibly some other option in there. I forget what the other defaults were set to.