hal.dll [RESOLVED in v2.0.11.43+]

CAVS beta 2.0 still has the hal.dll error. I never installed beta 1.1 because of this, but decided to give beta 2.0 a try. After rebooting a couple of times and a few hours of playing with it, some programs wouldn’t start, missing dlls or other errors. I rebooted (once more) and got the hal.dll message. Windows cd-rom doesn’t start up and I can’t access the bios. Be careful with CAVS beta!


edit: I found the bios and managed to start Windows XP cd-rom, but it can’t find the harddisk.

Yeah, I had the hal.dll problem with v1.1 and had to buy a new HDD to resolve the problem. It took a couple of days (and nights!) to sort it out… it really is a major problem if it happens. I have tried v2.0 and so far no hal.dll problem.

George: What could not find your HDD, the BIOS or XP?

booglywoogly: Wow. Couldn’t you have just reformatted the HDD? Do you still have it?

Hi, Well, I hope you didn’t spend too much :slight_smile: If you kept getting hal.dll errors and this was unresolvable, then I would dare say you had bad sectors. However, as mentioned, a simple reformat first to solve the corrupt OS, perhaps a Windows repair install, or a sfc /scannow. There are other fixes too. Then if need be a re-format re-install may have worked just fine. A software program did not ruin your drive sorry to say. Like I mentioned, if it kept happening after you did the above, you had bad sectors which even in that case, XP will not “repair” but skip over when you do an install. Still a good sign you should buy a drive. You didn’t mention the age of the drive either, which doesn’t ALWAYS matter as I have had new ones go Kaput.
If someone told you , you needed a new drive for a hal.dll problem, you need to come back here and ask me from now on. :wink:

Hi all,

Well, I didn’t want to reformat because I had all my work data on it (I work from home and I now do daily backups ;)). Windoze repair didn’t work, it wouldn’t even recognise the HDD. So, I bought a new HDD (I’m not complaining about it; actually, I was quite pleased to buy a new 200GB drive). I installed it as the master drive and set the old one as a slave. Once windoze was installed I copied all my data over to the new drive and then formatted the old one and reinstalled windoze. At the same time I installed Ubuntu and the GRUB boot manager so now I can boot into Ubuntu OR a test version of windoze (where I test all my security apps, like Comodo v2.0, etc) OR my “stable” version of windoze!


You may think that the failure wasn’t caused by software, but I do. The drive was only a year old and I had never had any problems with it.

Could you send us the troubleshhot log by attaching the victim HDD to another HDD as secondary. From that log we may find the reason of such problem.
CAV could not be the cause for such system files(hal.dll etc) deletion.
Reason: CAV does not delete any file unless until user choose on-demand scans and choose delete for detected but not disinfected files. CAV on-access does not have delete options at all. It can quarantine the files for detected but not disinfected files. And user must get CAV on-access virus alert message for every quarantined files. But no user has confirmed that they got CAV virus alert for hal.dll or other system .dll and it was quarantined.

This may be viral behavior pl see the following links: (Note: If you find GalaxyAngelEternalLovers.doc in your system, pl send it to us and remove it from your system. This is the source of such virus)
I would like to mention that a worm “W97M.Ortant@mm” will delete some antivirus files and deletes system files (including hal.dll).
The link for the description of the worm is at Risk Detected . Its behaviour is similar to that of DLL file deletions mentioned in https://forums.comodo.com/index.php/topic,3694.msg27944.html#msg27944 . The log from the user system will help us to investigate further.

The recent incident by this worm was mentioned in expert-exchange forum. Posted date : 07/07/2006
Link : Solved: Possible virus/trojan/worm here? | Experts Exchange

  • Note : There are no traces of this malware in CAVS installation files.

Some other issues which may cause this:
The links that shows the “Missing hal.dll” problem are as follows,

McAfee Installation : http://www.computing.net/windowsxp/wwwboard/forum/151844.html
HP version incompatibility : http://h10025.www1.hp.com/ewfrf/wc/genericSoftwareDownloadIndex?lc=en&cc=us&softwareitem=pv-19819-2
Driver Updates : Windows Driver Download and Update | DriverGuide
Nero Suite : http://club.cdfreaks.com/printthread.php?t=108663

[quote author=booglywoogly link=topic=3735.msg28410#msg28410 date=1162882039
You may think that the failure wasn’t caused by software, but I do. The drive was only a year old and I had never had any problems with it.
Hi. Please take no offense but I know for a fact it didn’t cause this. I have been repairing computers for quite some time and would hope I know what I am talking about otherwise my customers wouldn’t be too pleased.

Aside from this, and once again, no offense but it’s impossible that a software wouldn’t allow you to access the bios, destroy your hard drive, etc… Now in my history of fixing computers, a couple of things are a bit confusing here. How did you copy your data from a drive you can’t recognize? Even as slave, “most likely” wouldn’t show your information if that badly damaged. It went from not being recognized to being recognized and you copying all your data? If the bios won’t recognize it, it won’t with another drive installed with Windows either. As well, you say windows cd wouldn’t start up, well if it didn’t find a drive, it won’t install. As for the bios, CAV is NOT in any way going to access this. What you had is a bad hard drive. So, it’s been a year huh? LOL. I chuckle(not at you) but because I replaced three Maxtors in a few months. All bad. One bad from install sounded like a welding arc, two others in 3 months time. This isn’t unusual and why I always keep my 1-2 year warranty paper. Also why backing up should be a standard by anyone and is a hard learned lesson if not. I would guarantee what you had was simply a corrupt OS and thought the hard drive shot , so bought a new one. You found the bios? The bios doesn’t go missing, this would mean a firmware breakdown in which case no recovery or the chip got up and decided to take a midnight stroll. Do you mean you found how to access the bios in Cmos setup? tapping some common keys F12, F8, F1, F2, Del ?

On to what I really believe happened…
As well, I will say for sure it wasn’t COMODO. >>hal.dll is a very common dual boot failure of some sort. This means you either had two OSs either two drives, or two OSs on one drive. This traces back to a corrupt boot.ini file. I use knoppix to go in and repair the boot.ini file, the hal.dll goes away and bam, OS back up most of the time. I would almost GUARANTEE you were dual booting.

Once again, I truly mean no offense but I would hope I know enough that impossibilities, especially this many together, are not going to happen and I simply think you misunderstand what happened and believe it to be CAV. It could have happened any day, it just seems it always picks times when people install new software. Not just hal.dll, but hard disk crashes, etc…which lead people to believe it’s software. Of course this makes sense, if you are using \putting the hard drive under strain, it stands to reason. I hope this makes sense to you a bit and why I am not trying to debunk you, just stating what can or can’t be. :wink:


P.S. Kishork covered the virus aspect very well so no need for me to go there :wink:

Hey paul,

While your info makes sense and is factual, hardware is, unfortunately, not the only cause. Bitter voice of experience speaking here.

Clean install of XP. clean install of CAVS2. ran for two days faultlessly. tonight - ■■■■ - hal.dll. nothing happening on the system at all, just sitting idle and up came the warnings about files being replaced by unknown versions. No chance of it being virus, there was no internet connection on that box - the plug got pulled immediately after the AV was authenticated. File and size count after killing the internet connection was identical to file and size count prior to killing it.

Can on ly be CAVS doing it, but its only doing it internittently.

Thank god for paragon drive backup.

ewen :slight_smile:

??? Excuse me, mate, but at no stage did I say that I couldn’t access the bios or that my hard drive had been destroyed! That’s how I managed to change the boot order (to CD for Windows Repair) and also set the old drive as slave and new one as master.

When I had the hal.dll error the PC could not boot into windows (but I COULD access the bios) and windows repair would not find the HDD. That does not mean that the contents of the drive could not be copied from it once my new HDD was installed as master with a new install of windows and the old HDD as slave. All the files could be accessed as a separate drive when it was set as slave but would not boot when set as master… got the hal.dll error. Personally, I think there was a problem with the MBR, caused by the installation of CAV v1.1.

Exactly! That’s why I had to buy a new drive. I could have formatted the drive and reinstalled windows but then I would have lost all my work files.

For some reason you think that the drive was badly damaged. I don’t think so… it is still installed in my PC and being used to dual boot Ubuntu and a version of windows for testing purposes. It works like a dream ;D

I only set my PC up to dual boot AFTER I had the hal.dll problem and had resolved it. I had been wanting to test out Ubuntu linux for a while and when I got this problem I saw the opportunity to buy a new HDD and give it a go in a dual boot environment (but installed on a different drive).


I apologize boogly woogly. I was going off George’s post and somehow mixed it in with yours. This was directed at George and somehow as stated, I mixed it up. No wonder it makes no sense to you. :smiley: I obviously thought yours was a part of Georges, or vice versa truly. My bad. Sorry. However, I stick to my statement as opposed to George’s post with bios, etc… :wink: Now your post makes sense to me as well :wink: Now Paulo will send me back to the cage, no water dish :cry:



Apology accepted. Just wanted to make things clear.

Ewen, you in Oz? Maybe this hal.dll error is a Oz-centric problem… I’m in Brissy! (:LGH)


Glad to hear, and understandably why you wanted to be clear. I am going to call this OZ fest, lol.


Ewen, as you will see, I corrected my post, got george’s mixed in with booglywoogly “wooly booly” :wink: Perhaps this is the PAC MAN version of CAV :smiley: C…

Hi Guys
Just a question which is a little bit off the track, but how many Aussies are on these posts. Booglywoogly Im from brissy as well, near Tingalpa.
Have a great day guys

Why dont you crate a new topic in General Discussion? Good idea, BTW, I’d be curious to see how many aussies are on here.

Ewen :slight_smile:

I’ll do it for you. It’ll be called OZ fest. :wink:


isn’t there a ■■■■ there called Foster’s? maybe Foster-Fest?

Hi Ewen,
Do you have some datas on other drive in the same disk or any other disk attached to this syetem? Or its having only one drive which was formated before fresh XP installation?

Could you do the following test.

  1. install on fresh xp as you did.
  2. Change the on-demand general setting to “Do not automatically disinfect and prompt for an action when the scan is complete”
  3. Scan complete system
  4. Check Does it detect any virus. Check that wheather they are dlls from system32 dirctory.
  5. Do not quarantine them that could be fasle positive.
  6. After scanning completes, send troubleshoot log to us.

Note: If on-demand does not detect any virus then you can say that there is no false positive. and CAV does not delete them.

Now, keep this sysetm isolated as you did. (disconnect it from internet and LAN). And let it run. If hal.dll problem comes, Pl send troubleshoot log to us. Also you can check that is there any file quarantined by CAV. The quarantined files are at %All Users%\Application Data\comodo\Comodo AntiVirus\Quarantine.


Please send the Troubleshoot Logs to analyse this issue. You can collect the logs from CAVS settings. Go to Settings->Reports. Click “Save log” will saves logs. If it is failed, copy this folder(%Documents and Settings%\All Users\Application Data\comodo\Comodo AntiVirus\TroubleShootLog) and send to us. This logs will help to us for further analysis.


Windows XP repair doesn’t recognize the HDD, the BIOS does