Hello! I’m glad you fixed the Gameguard issue but, now, we got another problem with Hackshield. Hackshield just can’t update itself so the game doesn’t open. Games with Hackshield can be found here http://dragonica.thqice.com/ and http://sunonline.webzen.net/
My info are as follow:
CPU 64bits
OS Vista Business SP2 32 bits fully updated
Security apps running, CIS with D+ and no AV and Avira Antivir.
To reproduce the bug just open any game with Hackshield, it won’t update and will close itself.
I tried to solve it making the executables trusted, put them under my own safe files with no success.
D+ and Firewall are both under safe mode, tried learning mode on both with no success.
No reboots and no BSODS.
I’m under an admin account with UAC disabled.

I hope that helps to solve the problem. I can’t post any logs because there are no logs concerning Hackshield.
EDIT: OK, I’ve found the log, it’s attached.

[attachment deleted by admin]

Does the same thing happen when you don’t run the game in the sandbox?

Yes, it does. But there are no logs.

Does the updater part need open ports for incoming traffic? See if there is blocked traffic in the Firewall logs.

In the past Comodo didn’t have problems with HackShield. I think AhnLabs updated it because other firewalls have problems also, most of them you can open the game but not connect to server. With Comodo you can’t even open the game because HackShield fails to initiate. According to Dragonica’s publisher you don’t need to open any ports to the game work.
I checked the firewall logs and no log about HackShield.

What happens when you disable D+ with "Deactivate Defense+ permanently (Requires a system restart) " (Defense + → Advanced → Defense + Settings)?

Thanks for your help, I decided to search the game’s forum and I found a fix. That fix worked and I’m able to open the game again.
For everybody who’s having issues with Dragonica HackShield, just download the fix here http://downloads.thqice.com/HShield.zip and unzip to the folder Release inside the game’s folder. Maybe it will work with other games as well. I didn’t test.

Can you explain what the fix does for the other users including me?

I’m not sure but looks like that fix is able to help HackShield with problems to update itself. It’s official, the download is at the game’s site. Maybe AhnLab already fixed its side.