Hacker, Comodo Alert "Your Computer is About to Join a New Network"

Several times over the past few months I heard someone talking through my computer speaker when connected to the internet. The computer will begin to act oddly, become unresponsive. Comodo would pop up an alert window letting me know my computer was ‘joining a network.’ The only way to stop this is to try to turn the computer off and if that fails pull the battery. My last computer crashed I believe because of this issue.

I have my firewall set to Paranoid and virus protection to On Access. When I stealth my ports to everyone, the setting does not save so I have to remember every time I long onto the internet to select that setting. It always defaults to the first option. Is there anyway to set the firewall to ALWAYS stealth my ports to EVERYONE. I do not want to join anyone’s network, I pay for my own, and do not want anyone using my network connection.

I have disabled the WiFi on the computer, even locked down the print function. What else can I do?


Start in F8 mode and check CIS settings.

Scan you computer with AV, look up if there are any exclusions, delete them before.

Check your Firewall settings, maybe you can post a screenshot of your global and app rulesets.

Check your D+ settings, if there are any entries of unknown software.

I have had issues where some imported configuration from an earlier version have not worked, eg FW indicating it was on but not filtering.

I think that you should first ensure your computer is clean by scanning with multiple AV as well as anti spyware / malware. There are plenty good free one available, CIS being one of them.

I also would perform a re-install of CIS, ensuring any old configuration is completely removed.

Hope this helps


I agree, I would definitely do a scan with a-squared free. It would also be a good idea to follow the procedures outlined in this thread.

Hi, It always defaults to the first option. is the usual and default action of the Wizard.
Yes, it’s dumb idea and can cause unnecessary stress so hopefully it will be changed soon.
See this thread for details [at]

But, since you have other ‘problems’ you can’t very well trust that what you see is just this Wizard default action so best to look under Global Rules, as suggested by Heffe D in that thread, or keep resetting it to ‘stealth my ports to everyone’ until you get the problem fixed.

Good luck :slight_smile:

All the best, woz of oz

There are also Ads on websites that “talk” with embedded audio in it, what exactly was said and could it have been an ad? What applications did you have active during this, and does it always happen on the same webpage etc?