GUI and remembering rules is slow

Hi,

So yesterday, I decided I would finally make the switch from v5.x to v6.x.
I did a complete uninstall of v5 (using the removal tool afterwards as well) before installing v6, so hopefully that isn’t causing any problems.
I’m having two main issues right now, the first being relatively less important than the second.

First, the GUI is rather sluggish for me. It takes about 10-20 seconds to open the main GUI from the tray icon, and another 10-20 seconds each to open any of the settings windows. (Sometimes I have to click twice, since it seems that it doesn’t “notice” the first click – but maybe that’s just a mistake on my part.)

Second, whenever a HIPS/Defense+ alert pops up and I have it set to remember my answer, it takes forever for it to actually “remember my answer” before continuing on. This behavior does not occur when the “Remember my answer” box is unchecked, nor does it seem to occur with firewall alerts (regardless of whether the box is checked or not).

I used Process Explorer to look at what’s going on, and this is what I have found to happen:

[ol]- Program does something that would trigger an alert from Defense+.

  • The cis.exe process (one of them, at least :slight_smile: ) briefly spikes to around 30% CPU (probably to load the alert message or something) and then the alert pops up.
  • I check “Remember my answer” and respond to the alert.
  • The cmdagent.exe process goes up to around 30% CPU for about 3-5 seconds, then returns to normal (0%).
  • Immediately afterwards, the “System” process goes up to around 20-40% CPU (it fluctuates between those values). When I right-click the process in Process Explorer and look at the threads it’s running, I see that the thread for cmdguard.sys is responsible for this CPU usage. This continues for about 50-60 seconds (!) before going back to normal. (The program that triggered the alert is still frozen during this time)
  • As the System process is finishing up whatever it’s doing, the CPU usage of the process that triggered the alert goes up to about 30-40% for another 10-15 seconds before going back to normal and then continuing its execution.[/ol]

Some general info about my configuration:
I run Windows XP SP3 (32-bit) on a netbook (1.6 GHz Intel Atom processor, 2 GB RAM – so yeah, it’s not exactly the fastest thing).
I use Comodo only for firewall & HIPS (the antivirus component is not installed).
I use MSE as my antivirus (I added the Comodo processes to the exceptions list already. I’ve also tried disabling MSE, but that doesn’t seem to have any effect whatsoever on the behavior described above.).
I removed all traces of any previous security software way back when I uninstalled them using both their uninstallers and their removal tools, so that (hopefully) shouldn’t be causing any problems.
As far as the actual configuration for Comodo, I have it set to the Proactive Security configuration.
Both the firewall and HIPS are set to Safe Mode.
I currently have very few rules set for either (I opted to start fresh instead of importing my old v5 configuration).
I disabled auto-sandbox (I prefer to use Sandboxie).
I also disabled Enhanced Protection Mode to see if it would make any difference (it didn’t).

Any ideas what’s going on here?

(On a side note, why am I getting so many more “direct disk access” alerts than I did with v5?)

My advice would be to once again perform a clean install by following the advice I give in this topic:

Then, after reinstalling CIS, do not change any settings. See if the problems continue. If they do please create a bug report for this.

Thanks.

I’ve actually tried that already (at first, I simply uninstalled v5, rebooted, and installed v6 without using any sort of removal tool, but then I ran into those problems and decided to try performing a clean reinstall).

I’ll try it one more time just to make sure, though.

Okay, so today, I uninstalled Comodo, rebooted into Safe Mode, ran the removal tool (as well as the removal tool for every other security product I have ever had installed on my computer and later uninstalled, just to be sure), rebooted, disabled my antivirus (just to be safe), installed Comodo, and rebooted.
I noticed that the first time I rebooted after installing Comodo, MSE was completely shut down (the service was stopped) even though all I had done was turn off the real-time protection. (This also happened the first time I tried installing Comodo v6.) Another reboot and it was back to normal (only real-time protection turned off).

In any case, with a fresh install with the default settings, the GUI slowness is still there.
The “Remember my answer” slowness is still there, although the lag is now about 20-30 seconds instead of 50-60.

If you uninstall MSE completely (don’t worry, you can reinstall it after checking) does the slowdown still occur?

After uninstalling MSE and performing yet another clean reinstall of Comodo, the slowdown still remains, although it is perhaps slightly better. (Either way, it still takes about 10 seconds to get around anywhere in the GUI, and 20 or so seconds to “Remember my answer” for HIPS rules.)

In that case this sounds like a bug to me. Please create a new topic for this in this section of the forum:

Be sure to use the format provided in this post:
https://forums.comodo.com/bug-reports-cis/new-format-draft-do-not-use-yet-being-updated-t90436.0.html;msg651613#msg651613
Just copy and paste the code. Then put your answers after the colons. Also, remember to attach the required files.

Let me know if you have any questions.

Thank you.

Is “turn on traffic animation” effects enabled under firewall? This use to slow down the GUI is v5 and before, especially when using skins/themes on CIS.

Do you have the latest version of CIS 6?