guard32.dll of comodo crashes cameyo app virtuliasation[M430][V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    yes you can every time,on windows 8 64bit,use cameyo and try ghost capture,it will fail,because of guard32.dll
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    try installing softwares in ghost capture of cameyo
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?:
    conflict FAQ --where is it,i searched google and this fourm
  • Any software except CIS/OS involved? If so - name, & exact version:
    cameyo version=2.0.882.0
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    rename guard32.dll to “C:\Windows\SysWOW64\guard32.dll.bak”
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
CIS =6.1.276867.2813

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    All, HIPS=safe, BBlocker=Partially limited, Firewall=Safe, AV=cloud is on
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from a CIS 5?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 8, 64bit, UAC=off, admin, VM not used
  • Other security/s’box software a) currently installed b) installed since OS: a=emsisoft antimalware b=None

i have attached crash dump and also an image
when you run cameyo,it crashes,when you try to install programs in ghost capture,so that you can make it portable,again installation fails,it says in crash dailog that guard32.dll is causing the crash,i checked the files properties of guard32.dll ,guard32.dll belongs to comodo

i have disabled emsisoft antimalware,it still crashes
launcher.exe of cameyo crashes,if it dosnt ,it will crash when you try to install software through ghost capture
cis diagnostic found no error,its in attachment
even killswitch fails
Mod edit: Fixed list tags, Captainsticks.

[attachment deleted by admin]

I hope you don’t mind, but I edited your first post so that it was in the correct format. For future reference, just copy the format directly and put your answers in between the lines. That makes it much easier to read. Please look through your first post and make sure all the information is correct.

For A6 can you please give the exact software version of cameyo you are using? Also, did you try the software conflict FAQ, as mentioned in A5? If not then please do and see if that helps.

For B1 please copy and paste the entire version number from the CIS About window. Also, please answer B5.

In addition, you still have not attached the CIS diagnostic report and the KillSwitch process dump. Please attach these to your first post.

Also, are you running the free version of Emsisoft or the paid one? If it is the paid one please try disabling it and see if there is any change in the behavior you experience.

Also, I’m trying to wrap my head around exactly what you are experiencing. Are you saying that whenever you run cameyo app virtualization it will crash? (You don’t mean that you are trying to run any Comodo files inside of it do you?) If not then how do you know that guard.dll is the cause? I apologize if I am missing something obvious, it’s just that your first post is not very detailed for how to reproduce this. Can you please add some more detail into your first post?

Thank you.

look at the attachment,it constains the crashdumps

It’s possible that this is simply an issue which can be solved by applying the correct rules to cameyo. For the time being I will move this to the help forums.

Hopefully someone there will be able to help you to figure out how to get them working well together. If it becomes apparent that this is an issue which cannot be solved by altering settings please send a PM to an active Mod and we can move it back to the bug reporting section.

Thank you.

Sorry,you are wrong

in hips,cameyo is an allowed application
in behaviour blocker,cameyo is added to exceptions
in sandbox,its set not to virtualise cameyo
in firewall,its an allowed application

its not a settings issue
from my guess guard32.dll is trying to inject into cameyo and the apps it tries to virtualise

I will try to reproduce the above on my Vista x64. It’s the only 64 bits I have.

What application are you reporting the bug for? I tried to ghost Opera browser but that did not give the guard32 alert.

What happens when you use the Installer/Updater or Window System Application policy in the process?

i CANT BELIVE ,A Global Moderator,Comodo’s Hero dosnt have access to win8 64–?

try installing ,through ghost capture mode(capture insatllation in virtual mode):::::::::::::
viper plagiarism software= Sign in to Viper
Brothersoft-Updater =
text aloud =
all my apps =

–updated downloader link of text aloud

[attachment deleted by admin]

Moderators are users just like yourself. :wink:

I have been playing around with this tool for a while to get a bit of an idea what is does, how it works and how it interacts with CIS.

Some preliminary findings. With the Behaviour Blocker enabled I don’t seem to get it to work. Even when I white list some of the files KS will say it is Trusted but runs partially limited.

I got better results with the BB disabled. Still I don’t know exactly how this program is supposed to work.

Can you test with BB disabled, HIPS enabled and give the Installer/Updater policy to at least the following processes:

With HIPS enabled you will get D+ alerts. Allow what Cameyo needs and see if you can get the program to work like it should.

The program with the CNET downloader is less suitable for testing as it will download files from the web. It adds an extra step.

I have had Viper installed successfully. Not sure how to run etc…

A program which creates its own virtual environment is likely to conflict with security tools with a sandbox (as a rule of thumb).

yes i tried disabling everything,it still fails,as the problem is with Guard32.dll,look at the attachment picture

[attachment deleted by admin]

The crash with the Brothersoft updater reproduces here on my Vista x64. It also happens when I add the following folders to the Exclusions of shellcode injections:
:x\users%username%\Documents\Cameyo apps*

Can you try and see if adding the above folders to the exclusions of shellcode injections reproduces on your system? It it does I would call this a bug and I will move it back to the bug report section.

sanji765, can you please check what EricJH mentioned? As he mentioned, if even adding the above to the exclusions does not solve the crash then this can be moved back to the bug reporting section.


Yes it does still crash,please move this bug to the bug report section.

Have you imported a configuration from a previous version of CIS?

This may have been mentioned earlier, but if it was I can’t find it. This information is required for me to be able to forward this to the devs.

Thank you.

Have U imported a config from a previous version of CIS:
if so, have U tried a standard config - if not please do:
yes,i have tried a standard config

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Actually, QA has determined that the instability arises from programming problems in the Cameo application. Please contact cameyo about this issue.

I will move this to Resolved.

yes the problem is resolved

““instability arises from programming problems in the Cameo application. Please contact cameyo about this issue.”” can you be more specific,so I can contact cameyo with more specific information,Thank you.

I’m sorry, but I do not have any additional information. I just passed along what QA told me. I believe cameyo should be able to replicate this, and thus determine if there is anything they can do.

I’m sorry, but I cannot help any more than that.